
eBook Sample Book

Copyright © Maplesoft, a
division of Waterloo Maple Inc.

2012



eBook Sample Book
Copyright

Maplesoft and Maple are trademarks of Waterloo Maple Inc.

© Maplesoft, a division of Waterloo Maple Inc. 1996-2011. All rights reserved.
No part of this book may be reproduced, stored in a retrieval system, or transcribed, in any form or by any
means — electronic, mechanical, photocopying, recording, or otherwise. Information in this document
is subject to change without notice and does not represent a commitment on the part of the vendor. The
software described in this document is furnished under a license agreement and may be used or copied only in
accordance with the agreement. It is against the law to copy the software on any medium except as specifically
allowed in the agreement.

Windows is a registered trademark of Microsoft Corporation.

All other trademarks are the property of their respective owners.

This document was produced using a special version of Maple and DocBook.



iii

Contents
 Preface ........................................................................................................  ix
1 Getting Started with Maple ............................................................................  1

1.1 In This Chapter .....................................................................................  1
1.2 Introduction to Maple .............................................................................  1

 Working in Maple ..................................................................................  1
 Starting the Standard Document Interface ...................................................  2
 Entering 2-D Math .................................................................................  3
 Toolbar Options .....................................................................................  6
 Context Menus and Copy & Drag .............................................................  8
 Saving a Maple Document .....................................................................  15

1.3 Entering Expressions ............................................................................  15
 Execution Groups .................................................................................  15
 Math Mode vs. Text Mode ..................................................................... 16
 Palettes ...............................................................................................  17

1.4 The Maple Help System ........................................................................  18
 Accessing the Help System ....................................................................  18
 Using the Help Navigator ......................................................................  19

 Index .........................................................................................................  21



iv   •   Contents



v

List of Figures
Figure 1.1: The Maple Environment ...................................................................  2
Figure 1.2: Text and Math Buttons on the Toolbar ...............................................  16
Figure 1.3: Sample Help Page .........................................................................  19



vi   •   List of Figures



vii

List of Tables
Table 1.1: Common Keystrokes for Entering Symbols and Formats ..........................  4
Table 1.2: Maple Toolbar Options ......................................................................  6
Table 1.3: Tab Icon Description .........................................................................  7
Table 1.4: Toolbar Icons and their Tools .............................................................  7
Table 1.5: Toolbar Icon Availability ...................................................................  8
Table 1.6: Math Mode vs. Text Mode ...............................................................  16
Table 1.7: Help Page Icons .............................................................................  20



viii   •   List of Tables



ix

Preface
In this Book
This sample book contains modified material from the Maple User Manual.

The source material for this book is found in the data/eBookTools directory of your
Maple installation. The source material includes the following MW files:

• Legal.mw

• Preface.mw

• GettingStartedWithMaple.mw

Creating a Book using this Source Material
You can use the eBook Publisher to create a book from these files.

1. From the Tools menu, select Assistants > eBook Publisher...

2. Add the three files to the project.

3. Set the book title to "eBook Sample Book".

4. Set the book name to "eBookSample"

5. Specify an output folder.

6. Optionally, specify other settings.

7. Specify the format(s) to build.

8. Click Build.

The progress bar and log display the progress of the build. When the build is complete,
the resulting book is saved to the output folder.
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1 Getting Started with Maple
1.1 In This Chapter
Section Topics
Introduction to Maple (page 1) - The main
features of Maple's Standard Interface

• Starting the Standard Document Interface

• Entering commands and mathematical
expressions

• Toolbars

• Context menus

• Copy and drag keys

• Saving Maple documents
Entering Expressions (page 15) - Methods
of entering expressions in 1-D and 2-D Math

• Execution groups

• Math Mode and Text Mode
The Maple Help System (page 18) -
Accessing help on commands, packages, point-
and-click features, and more

• How to access help for Maple features

1.2 Introduction to Maple

Working in Maple

With Maple, you can create powerful interactive documents. The Maple environment lets
you start solving problems right away by entering expressions in 2-D Math and solving
these expressions using point-and-click interfaces. You can combine text and math in
the same line, add tables to organize the content of your work, or insert images, sketch
regions, and spreadsheets. You can visualize and animate problems in two and three
dimensions, format text for academic papers or books, and insert hyperlinks to other
Maple files, web sites, or email addresses. You can embed and program graphical user
interface components, as well as devise custom solutions using the Maple programming
language.
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Figure 1.1: The Maple Environment

Starting the Standard Document Interface

To start Maple on:

Windows From the Start menu, select All Programs → Maple 16 → Maple 16.

Alternatively:

Double-click the Maple 16 desktop icon.
Macintosh 1. From the Finder, select Applications and Maple 16.

2. Double-click Maple 16.
UNIX Enter the full path, for example, /usr/local/maple/bin/xmaple

Alternatively:

1. Add the Maple directory (for example, /usr/local/maple/bin) to your
command search path.

2. Enter xmaple.
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Entering 2-D Math

In Maple, the default format for entering mathematical expressions is 2-D Math. This
results in mathematical expressions that are equivalent to the quality of math found in
textbooks. Entering 2-D Math in Maple is done using common key strokes or palette
items. For more information on palettes, see Palettes (page 17). An example of
entering an expression using common key strokes is presented in the following section.

Common Operations

Entering mathematical expressions, such as , , and  is natural in 2-D

Math.

To enter a fraction:

1. Enter the numerator.

2. Press the forward slash (/) key.

3. Enter the denominator.

4. To leave the denominator, press the right arrow key.

To enter a power:

1. Enter the base.

2. Press the caret (^) key.

3. Enter the exponent, which displays in math as a superscript.

4. To leave the exponent, press the right arrow key.

To enter a product:

1. Enter the first factor.

2. Press the asterisk (*) key, which displays in 2-D Math as a dot, .

3. Enter the second factor.

Implied Multiplication:

In most cases, you do not need to include the multiplication operator, . Insert a space
character between two quantities to multiply them.

Note: In some cases, you do not need to enter the multiplication operator or a
space character. For example, Maple interprets a number followed by a variable as
multiplication.
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Important: Maple interprets a sequence of letters, for example, xy, as a single
variable. To specify the product of two variables, you must insert a space character (or
multiplication operator), for example, x y or . For more information, refer to the
2DMathDetails help page.

Shortcuts for Entering Mathematical Expressions

Table 1.1: Common Keystrokes for Entering Symbols and Formats

Symbol/Formats Key Example
implicit multiplication

 

Space key

explicit multiplication * (asterisk)

fraction / (forward slash)

exponent (superscript) ^ (Shift + 6 or caret key)

subscript _ (Shift + underscore )

navigating expressions

 

Arrow keys  

command / symbol
completion

 

 

• Esc, Macintosh,Windows,
and UNIX

• Ctrl + Space, Windows

• Ctrl + Shift + Space, UNIX

square root sqrt and then command
completion

exponential function exp and then command
completion

enter / exit 2-D Math • F5 key

• Math and Text icons in the
toolbar

 versus  1/4

 required for products of numbers

 use the right arrow key to leave a denominator, superscript, or subscript region

For a complete list of shortcut keys, refer to the 2-D Math Shortcut Keys and Hints
help page. For information on the Maple Help System, see The Maple Help System (page
18).



1.2 Introduction to Maple   •   5

Example 1 - Enter and Evaluate an Expression Using
Keystrokes

Review the following example:

In this example, you will enter  and evaluate the expression.

Action Result in Document
To enter the expression:

1. Enter x.
2. Press Shift + 6 (the ^ or caret key). The cursor moves to the

superscript position.
3. Enter 2.

4. Press the right arrow key. The cursor moves right and out of the
superscript position.

5. Enter the + symbol.

 
6. Enter y.

7. Press Shift + 6 to move to the superscript position.

8. Enter 2 and press the right arrow key.

9. With the mouse, select the expression that will be the numerator
of the fraction.

 
10.Enter the / symbol. The cursor moves to the denominator, with the

entire expression in the numerator.

11.Enter 2.

12.Press the right arrow key to move right and out of the
denominator position.

To evaluate the expression and display the result inline:

13.Press Ctrl + = (Command + =, Macintosh).  = 
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To execute 2-D Math, you can use any of the following methods.

• Pressing Ctrl + = (Command + =, for Macintosh). That is, press and hold the Ctrl
(or Command) key, and then press the equal sign (=) key. This evaluates and displays
results inline.

• Pressing the Enter key. This evaluates and displays results on the next line and
centered.

• Right-click (Control-click for Macintosh) the input to invoke a context menu item.
From the context menu, select Evaluate and Display Inline.

• Using the Edit menu items Evaluate and Evaluate and Display Inline.

Toolbar Options
The Maple toolbar offers several buttons to assist you when interacting with Maple. See
Table 1.2.

Table 1.2: Maple Toolbar Options

Basic Usage Icon Equivalent Menu Option or Command
Inserts plain text after the current
execution group.

From the Insert menu, select Text.

Inserts Maple Input after the current
execution group. For details, refer to
Execution Groups (page 15).

From the Insert menu, select Execution
Group and then After Cursor.

Encloses the selection in a subsection. From the Format menu, select Indent.

Removes any section enclosing the
selection.

From the Format menu, select Outdent.

Executes all commands in the
worksheet or document

From the Edit menu, select Execute and
then Worksheet.

Executes a selected area. From the Edit menu, select Execute and
then Selection.

Clears Maple's internal memory. For
details, refer to the restart help page.

Enter restart.

Add and edit Maple code that is
executed each time the worksheet
is opened. For details, refer to the
startupcode help page.

From the Edit menu, select Startup Code.

Adjusts the display size of document
content. Note: plots, spreadsheets,
images, and sketches remain
unchanged.

From the View menu, select Zoom Factor
and then a zoom size.

Opens the Maple help system. For
details, refer to The Maple Help
System (page 18).

From the Help menu, select Maple Help.
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For 1-D Math and text regions, the Tab icon in the toolbar allows you to set the Tab key
to move between placeholders (or cells in a table) or to indent text.

Table 1.3: Tab Icon Description

Tab Icon Description
Tab icon off. Allows you to move between placeholders using the Tab key.

Tab icon on. Allows you to indent in the worksheet using the Tab key.

The Tab icon is disabled when using 2-D Math (Math mode), and as such, the
Tab key allows you to move between placeholders.

Toolbar icons are controlled by the location of the cursor in the document. For example,
place the cursor at an input region and the Text and Math icons are accessible while the
others are dimmed. See Table 1.4 for a list of the tools available in each icon.

Table 1.4: Toolbar Icons and their Tools

Toolbar Icon Options
Text tools

Math tools

Drawing tools

2-D Plot tools

3-D Plot tools
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Toolbar Icon Options
Animation tools

Table 1.5: Toolbar Icon Availability

Region Available Tools
Input region\011 Text and Math icons
Plot region Drawing and Plot icons
Animation region Drawing, Plot, and Animation icons
Canvas and Image regions Drawing icon

The Text and Math icons allow you to enter text and math in the same line by choosing
the appropriate input style at each stage when entering the sentence.

The derivative of  is .

Using the tools available in these icons, you can customize the input style of the text and
2-D Math. For the Text and Math icons, the icon that is selected remains in that state
until prompted otherwise; therefore, if the Text icon is selected and you press the Enter
key, the new input region remains a Text region.

The Text and Math icons differ while at a Maple input prompt. The Math icon displays
input as 2-D Math, whereas the Text icon displays Maple input. For details, refer to Math
Mode vs. Text Mode (page 16).

>

> x^2/2;

To access the tools available in the Plot and Drawing icons, click a plot region. These
tools allow you to manipulate the plot or draw shapes and enter text on the plot region.
By clicking an animation region, you have the same features available for a plot region,
in addition to tools for playing the animation in the Animation icon.

For the remaining icons, hover the mouse over the icon to display the icon description.

Context Menus and Copy & Drag

Context Menus

Maple dynamically generates a context menu of applicable options when you right-click
an object, expression, or region. The options available in the context menu depend on the
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selected input region. For example, you can manipulate and graph expressions, enhance
plots, format text, manage palettes, structure tables, and more. When using context menus
to perform an action on an expression, the input and output are connected with a self-
documenting arrow or equal sign indicating the action that had taken place.

Copy & Drag

With Maple, you can drag input, output, or curves in a plot region into a new input
region. This is done by highlighting the input or selecting the curve and dragging it with
your mouse into a new input region. Dragging the highlighted region will cut or delete
the original input. To prevent this, use the copy and drag feature.

• Ctrl + drag, Windows and UNIX

• Command + drag, Macintosh

That is, highlight the region you want to copy. Press and hold the Ctrl key while you drag
the input to the new region using the mouse. The steps are the same for Macintosh with
the exception of pressing the Command key.

Example 2 - Solve and Plot an Equation Using Context Menus
and Copy & Drag

Review the following example:

In this example, we will enter the equation and then solve and plot the equation using
context menus and Maple's copy & drag feature. This example will only refer to the
keystrokes needed on a Windows operating system to invoke the context menus and the
copy & drag feature. The shortcut keys for your operating system can be viewed from the
Help menu (Help → Manuals, Resources, and more → Shortcut Keys).
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To solve the equation:

1. Enter the equation.

2. Right-click the equation and select Move to Left.

 

Input:

Result:

  

 

A brief description, "move to left" is displayed above the arrow that connects the input and output.
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3. Right-click the output from the previous action, , and select Solve → Isolate
Expression for → x.

 

 

Input:

Result:
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Now that we have solved the equation, we can plot it. To do this, we will copy the equation
to a new document block and use context menus again.

 

4. From the Format menu, select Create Document Block.

5. To copy the expression , highlight only this expression from the previous result.
Press and hold the Ctrl key and drag the expression to the new document block region.

 

Result:
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To plot the expression:

6. Right-click the equation, and select Left-hand Side.

Input:

 

Result:

  

 

7. Right-click the expression and select Plots → 2-D Plot.
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Input:
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Result:
 

 

Saving a Maple Document
To save these examples you created, from the File menu, select Save. Maple documents
are saved as .mw files.

1.3 Entering Expressions
Execution Groups
An execution group is a grouping of Maple input with its corresponding Maple output.
It is distinguished by a large square bracket, called a group boundary, at the left. An
execution group may also contain any or all of the following: a plot, a spreadsheet, text,
embedded components, and a drawing canvas.

Execution groups are the fundamental computation and documentation elements in the
document. If you place the cursor in an input command and press the Enter or Return
key, Maple executes all of the input commands in the current execution group.



16   •   1 Getting Started with Maple

Math Mode vs. Text Mode
The default mode of entry in Document or Worksheet mode is Math Mode, which
displays input in 2-D Math. In earlier releases of Maple, commands and expressions were
entered using Maple Input or 1-D Math.

Important: With Maple input, you must terminate commands with a semicolon or colon.

> cos(alpha)^2+sin(alpha)^2;

> a*int(exp(sqrt(2)*x),x);

> limit(f(x),x=infinity);

> sum(a[k]*x^k, k=0..m)=product(b[j]*x^j, j=0..n);

In Document Mode, to enter input using Maple Input mode, insert a Maple prompt by

clicking  in the toolbar, and then click the Text button in the toolbar. In Worksheet
Mode, simply click the Text button. See Figure 1.2.

Figure 1.2: Text and Math Buttons on the Toolbar

Table 1.6: Math Mode vs. Text Mode

Math Mode Text Mode
Maple's default setting. Executable
standard math notation. This is also
referred to as 2-D Math Input.

>

Executable Maple notation. This is also
referred to as 1-D Math Input or Maple
Input.

> int(x^2+2*x+1, x);
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Math Mode Text Mode
Access from the Insert → 2-D Math menu. Access from the Insert → Maple Input menu.
When using 2-D Math, the Math mode icon is

highlighted in the toolbar, .

When entering Maple Input or text in a text
region, the Text mode icon is highlighted in the

toolbar, .
In Document Mode (or a document block), input
is entered in a document block with a slanted

cursor, .

In Document Mode (or a document block), input
is entered with a vertical cursor, as plain text,

.

In Worksheet Mode, input is made at an input

prompt with a slanted cursor, .

In Worksheet Mode, input is made at an input

prompt with a vertical cursor, .
To convert a 2-D Math expression to 1-D Math,
right-click the expression (Command-click,
Macintosh) and select 2-D Math → Convert To
→ 1-D Math Input.

To convert a 1-D Math expression to 2-D Math,
right-click the expression (Command-click,
Macintosh) and select Convert To → 2-D Math
Input.

No termination symbol is required. All input must end with a semi-colon ( ; ) or a
colon ( : ).

Palettes make entering expressions in familiar
notation easier than entering foreign syntax and
reduces the possibility of introducing typing
errors.

Using palettes while in 1-D Math teaches you
the related Maple command syntax.

If you prefer 1-D Math input, you can change the default math input notation.

To change math input notation for a session or globally across all documents:

1. From the Tools menu, select Options. The Options Dialog opens.

2. Click the Display tab.

3. In the Input Display drop-down list, select Maple Notation.

4. Click the Apply to Session or Apply Globally button.

Important: The new input display becomes the default setting after pressing the Enter
key.

Palettes
Palettes are collections of related items that you can insert into a document by clicking
or drag-and-dropping. The Maple environment provides access to over 20 palettes
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containing items such as symbols , layouts mathematical operations

and much more.

By default, palettes are displayed in the left pane of the Maple environment when you
launch Maple. If the palettes are not displayed,

1. From the View menu, select Palettes.

2. Select Expand Docks.

3. Right-click (Control-click, Macintosh) the palette dock. From the context menu,
select Show All Palettes.

Alternatively, from the main menu, select View → Palettes → Arrange Palettes to
display specific palettes.

You can create a Favorites palette of the expressions and entities you use often by right-
clicking (Control-click, Macintosh) the palette template you want to add and selecting
Add To Favorites Palette from the context menu.

1.4 The Maple Help System
The Maple program provides a custom help system consisting of almost 5000 reference
pages. The help system is a convenient resource for determining the syntax of Maple
commands and for learning about Maple features.

Accessing the Help System

There are several ways to access the Maple help system:

• From the Help menu, select Maple Help

• Click  in the toolbar

To get help on a specific word:

• In a document, place the insertion point in a word for which you want to obtain help.
From the Help menu, select Help on .... Alternatively, press F2 (Control + ?, for
Macintosh) to access context-sensitive help.

• In a document, execute the command ?topic, for example, enter ?LinearAlgebra and
press Enter

The Maple help system opens in a separate window with two panes. The left pane
contains the Help Navigator where you initiate searches and browse the table of contents,
and the right pane displays the final search result, such as a specific help page.
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Figure 1.3: Sample Help Page

Every help page in Maple lists the command's calling sequence, parameters, and a
description, with examples of the command at the end of the page. Some help pages
also contain hyperlinks to related help pages and hyperlinks to dictionary definitions.
Hyperlinks to help pages display in green, while hyperlinks to dictionary definitions
display in dark red.

Using the Help Navigator

The Help Navigator contains a field for topic or text-based searches. The Table of
Contents tab provides a structured list of all topics in the help system.

To search the help system:

1. In the left pane, enter a string in the search field.

2. By default, a topic search is performed. To perform a text search, select the Text radio
button.

3. Enter the term and click Search.
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• Topic searches reveal a list of matching topics sorted by the precision of the match.

• Text searches reveal a list of topics based on keyword frequency.

• You can search all of the help system or specific Resources such as Help Pages, Tasks,
Tutorials, and Manuals by selecting the Resources drop-down menu.

Search results are displayed as a list in the Search Results tab of the left pane. Click the
Table of Contents tab to view a structured list of all topics in the help system.

To display potential matches in the right pane, click a topic preceded by an icon. Table
1.7 describes the different icons.

Table 1.7: Help Page Icons

Icon Description
A folder icon in the Table of Contents tab indicates that a topic can be expanded
into subtopics.

Question mark icon indicates a help page and displays the associated help page in the
right pane when selected.

WS icon indicates an example worksheet. Example worksheets open in a new tab in
the Maple document.

D icon indicates a definition and displays the associated dictionary definition in the
right pane when selected.

T icon indicates a Task template and displays the associated Task Template in the
right pane when selected.

M icon indicates a manual. Manuals open in a new tab in the Maple document.
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