Question: deficiencies in printing output caused by installa...


To ensure the general accessibility of my Maple worksheets for Mathematics for Chemistry, I work with the classic interface.  When I tried to install first Maple 2018.1, when it became available, and then Maple 2018.2 when it became available, the output from use of either technical input in text lines, using function key F5, or simply from an executable input command or statement was corrupted.  I reported this behaviour but apparently the remedy has not yet been incorporated.  To avoid these problems, I had to delete Maple 2018.2 and to reinstall Maple 2018.0.  

     When I, in good faith, with that Maple 2018.0 reinstalled tried to install Maplesoft Physics Updates version 241, according to the encouragement of Edgardo Cheb-Terrab above, I discovered the same corruption in the output when I entered a procedure, for instance this one,

ft := proc(kk,ll,mm)
>      h^(-3/2)*int(int(int(expand(exp(-(2*Pi*I/h)*(sin(theta)*sin(Theta)*cos(Phi-phi)+cos(theta)*cos(Theta))*r*P)
>            *eval(psi,[k=kk,l=ll,m=mm])*r^2*sin(theta), trig),phi=0..2*Pi),theta=0..Pi),r=0..infinity);
> end proc;
  ft := proc(kk, ll, mm)
    1/h^(3/2)*int(int(int(expand(exp(-2*I*Pi*(in(theta)*sin(Theta)*cos(Phi - phi)+ cos(theta)*cos(Theta))*r*P/h)*eval(psi, [k = kk, l = ll,  m = mm])*r^2*sin(theta), trig), phi = 0 .. 2*Pi), theta = 0 .. Pi), r = 0 .. infinity)
end proc

namely that, instead of * in any location in the output that you can read above, there appears a large U.  Why is the testing by Dr. Cheb-Terrab and others connected with Maplesoft done in such a slipshod manner?  After all these years one should expect better control of quality than is evidently the case.  It seems that I must once again reinstall Maple 2018.0 to regain the full functionality of Maple 2018 without the deficiencies introduced in both the updates and the Physics package.  This condition is disgraceful and intolerable.

Please Wait...