Question: why some PDE's are not solved when upgraded to new version of Physics package?


I am not sure what happened, but now after starting Maple, these PDE's no longer hang. Even though I tried them before number of times before posting to make sure.  This is strange. I do not know what happened.

Any way, there is no issue any more. These do not hang in version 319.

original post

Hello Maple experts.

FYI, I noticed some pde's are no longer solved (hang) after downloading latest physics package cloud version 319, when before when using version 301 these were solved.

 User Interface: 1362973
         Kernel: 1362973
        Library: 1362973
 "C:\Maple_updates\Physics_Updates_319.maple", 2019, March 3, 
    17:7 hours, version in the MapleCloud: 319, version installed in this 
    computer: the "Physics Updates" is not  installed.

Any idea why this happened? It is possible this is due to bug fix of course, but thought to point this out.

These PDE's were solved with Maple 2018.2.1 with Physics ver. 301 but not in ver. 319

#now not solved or hangs, before it was solved in 7 seconds
pde := diff(u(x, t), t) = (1/20)*(diff(u(x, t), x$2))+t;
bc := u(0, t) = 5, (u(1, t)+ eval( diff(u(x,t),x),x=1)) = 10;
ic:= u(x, 0) = -40*x^2/3+45*x/2+5;
pdsolve([pde, bc,ic], u(x, t));

#now it hangs, before it was solved in 0.2 seconds
pde :=  (A*y^2+B*x^2-a^2*B)*diff(w(x,y),x)+(C*y^2+2*B*x*y)*diff(w(x,y),y) = 0;

#now hangs when it was solved before in 5 seconds
pde := 2*diff(w(x,y),x)+((lambda+a-a*sin(lambda*x))*y^2 +lambda -a -a*sin(lambda*x))*diff(w(x,y),y) = 0;

#now hangs when it was solved before in 1.8 seconds
pde := diff(w(x,y),x)+((lambda+a*sin(lambda*x)^2)*y^2 + lambda -a +a*sin(lambda*x)^2)*diff(w(x,y),y) = 0;

Using windows 10.


Please Wait...