Question: computing a residue

Dear friends,

I ran into another problem while using Maple to do residue calculus. The following call

residue(1/x^(1/3)/(x^2+2*x*cos(phi)+1), x=-exp(I*phi));

returns zero -- it does not recognize the residue. On the other hand, if I do a subsitution like this

subs(x=-exp(I*phi), 1/x^(1/3)/(x^2+2*x*cos(phi)+1));

followed by

convert(%, trig); simplify(%);

then I get a divide by zero error, which shows that the pole is there. Even when we leave out the power of


which might cause problems owing to the fact that we have a branch cut connecting zero to infinity, the residue is still not found. The call

residue(1/(x^2+2*x*cos(phi)+1), x=-exp(I*phi));

is zero again but the substitution

subs(x=-exp(I*phi), 1/(x^2+2*x*cos(phi)+1));

followed by

convert(%, trig); simplify(%);

produces the divide by zero. Curiously enough, the call to


does find the right singularities, but does not express them in their simplest form. If this is what's used internally that could explain why it does not recognize that the two expressions of the pole represent the same complex number.

Marko Riedel

Read more about it: here

Please Wait...