Denis

Mr. Denis Semenov

25 Reputation

6 Badges

9 years, 171 days
Saint Petersburg, Russian Federation

MaplePrimes Activity


These are replies submitted by Denis

@Markiyan Hirnyk re-uploaded file is still unavailable. Maybe server problem?

I can transfer the file to you in any other way

 

re-uploaded_resp1.mw

@Markiyan Hirnyk Here is the executed file. 

mp_qn_double_integra.mw

@Axel Vogt First of all, thank you for the answer. It was helpful for me.

As I understood the idea was to symbollically calculate the integral. (V1:=value(%) assuming 0<C);

It takes about 10 sec on my machine. After that I can fing C either by fsolve or by solve.

The executed file is uploaded. 

But 10 seconds is too much for solving that task, it looses practical significance in that case.

Is there any way to accelerate? (I suppose the numerically solution of original eq1 has to be quicker, but I can't understand why it doesn't work...)

mp_qn_double_integra.mw

 

 

@Markiyan Hirnyk 

I achieved the same result as you executing the file.

 

I still can not understand why every surface (eq1 and eq2) is plotting so good by implicitplot3d in few seconds,

but finding the intersection of them is unsolvable task for intersectplot???

 

Thank you for you help and time!

@Markiyan Hirnyk 

I achieved the same result as you executing the file.

 

I still can not understand why every surface (eq1 and eq2) is plotting so good by implicitplot3d in few seconds,

but finding the intersection of them is unsolvable task for intersectplot???

 

Thank you for you help and time!

You mean the problems are because of the very complicated equations?

But in this case why implicitplot3d builds plot of eq1 without any problem?

You mean the problems are because of the very complicated equations?

But in this case why implicitplot3d builds plot of eq1 without any problem?

Thank you for help and your time to examine my problem.!

I have to admit that since my posted question I have found some errors in the file and now I consider another
values for N, Mx, My (N=141.63, Mx=83.95 and My=6.66) in test example. But your conclusion that system has no real solutions is also true for that new values of N, Mx, My. (I checked directsearch and implicitplot3d as you do). the corrected version of file is uploaded here:

fsolve_mp_v2.mw

But I definetely sure that system has real solutions. Here is my provement (by the means of considering inverse problem):

First of all, I checked for correctness the entered formulas and equations by considering the inverse problem – I assumed the parameters ebfib=0.0020; C1=0.000; β=20*3.14/180 and based on it I achieved the values N=141.63, Mx=83.95 and My=6.66 (approximately). I explored functions e(x, y) and sigmab(x,y) via 3dplot and It was adequate.

After that I made an conclusion that there were no typos and other errors in the code and I can start to consider the direct problem. I expect to define N=141.63, Mx=83.95 and My=6.66 and to receive ebfib=0.0020; C1=0.000; β=20*3.14/180 as a solution of system of equations eq1, eq2 and eq3.

I tried many variants (including symbolically solution) but the fsolve can't manage to solve that system, I have been waiting up to 2 hours and its still evaluating... I tried to simplify the task and define 2 of 3 unknowns and solve the eq1, Maple found solution and it takes 13 sec. After that I define 1 of 3 unknowns and tried to solve the system of eq1 and eq2 - Maple didn't return the answer after 2 hours of calculations. 

The question is appeared, Is the system of equations so complicated and can't be solved in Maple during reasonable time or there is a my bad usage of Maple? what's wrong?

 

Thank you for help and your time to examine my problem.!

I have to admit that since my posted question I have found some errors in the file and now I consider another
values for N, Mx, My (N=141.63, Mx=83.95 and My=6.66) in test example. But your conclusion that system has no real solutions is also true for that new values of N, Mx, My. (I checked directsearch and implicitplot3d as you do). the corrected version of file is uploaded here:

fsolve_mp_v2.mw

But I definetely sure that system has real solutions. Here is my provement (by the means of considering inverse problem):

First of all, I checked for correctness the entered formulas and equations by considering the inverse problem – I assumed the parameters ebfib=0.0020; C1=0.000; β=20*3.14/180 and based on it I achieved the values N=141.63, Mx=83.95 and My=6.66 (approximately). I explored functions e(x, y) and sigmab(x,y) via 3dplot and It was adequate.

After that I made an conclusion that there were no typos and other errors in the code and I can start to consider the direct problem. I expect to define N=141.63, Mx=83.95 and My=6.66 and to receive ebfib=0.0020; C1=0.000; β=20*3.14/180 as a solution of system of equations eq1, eq2 and eq3.

I tried many variants (including symbolically solution) but the fsolve can't manage to solve that system, I have been waiting up to 2 hours and its still evaluating... I tried to simplify the task and define 2 of 3 unknowns and solve the eq1, Maple found solution and it takes 13 sec. After that I define 1 of 3 unknowns and tried to solve the system of eq1 and eq2 - Maple didn't return the answer after 2 hours of calculations. 

The question is appeared, Is the system of equations so complicated and can't be solved in Maple during reasonable time or there is a my bad usage of Maple? what's wrong?

 

@acer thank you for the information

@acer thank you for the information

Thank you!

Thank you!

1 2 3 Page 1 of 3