bjdehart

10 Reputation

One Badge

8 years, 103 days
University of Waterloo

MaplePrimes Activity


These are replies submitted by bjdehart

@Bendesarts 

The default value will only be used if it appears in the Inspector tab in the Schematic view. In other words, if you don't delete the '1', then the value that is used will be 1.

Since this is a standalone subsystem, you can do one of two things to achieve your goal: either enter the values as defaults and delete the '1' values (as described above), or enter your custom values/equations directly into the Inspector tab so that the default values are ignored.

If you're planning to use more than one copy of the subsystem, then you should convert the subsystem to a shared subsystem. For shared subsystems, the easiest way to do what you want is to define all of your default values directly in the Default Value fields in the Parameters area. If you then make a copy of the subsystem and delete the original, the copied subsystem (and any other copies you make) will automatically have all of the parameters in the Inspector tab populated with your default values.

Happy to help!

Cheers,

Brandon

@Bendesarts 

The values that you set in the Parameters area of the subsystem are the default values, which were originally set to 1 when the parameters were created. If you delete the '1' values shown in the Inspector, then the default values will appear.

Cheers,

Brandon

@Bendesarts 

Hi Bendesarts,

I've just tried putting the same relation as above in as a parameter, and it worked fine. Can you maybe describe what kind of issues you are having with trying to do this?

Cheers,

Brandon

Page 1 of 1