MaplePrimes Commons General Technical Discussions

The primary forum for technical discussions.
I'm running Maple 10.02, Mac OS X.4.3, and Java 1.5, and when I give Maple an inverse laplace transform with a number, it returns the correct answer. But when I give it the same thing but replace the number with an arbitrary constant (i.e., I replaced 4 with k) it doesn't seem to be able to figure it out. Any suggestions on this?

> Maple Equation

I had been following a thread on comp.soft-sys.math.maple titled: Maple missing solutions?

http://groups.google.com/group/comp.soft-sys.math.maple/browse_thread/thread/0dc424e68954103e/9511b79909ecf139?hl=en#9511b79909ecf139

In, short the OP was missing solutions to a set of equations involving sin and cos.

A respondent suggested converting to exp, which seems to have worked very well in that case.

For no particular reason I decided to try this with another equation and got some

results which I cannot explain. As follows:

> S1:=[solve(sin(x)=sin(1/x))];

A student of mine recently asked what algorithm Maple uses to calculate Eigenvalues. So, I tried diving into Maple Procedures. For example: >showstat(`Eigenvalues`); LinearAlgebra:-Eigenvalues := proc(A) .. [error catchers ommitted] .. 17 LinearAlgebra:-LA_Main:-Eigenvalues(`if` ... end proc How should I interpret that last line? Can I get Maple to show me what that procedure does? So far I've no luck cracking it. Also, is this the best/easiest way of going about learning what types of algorithms Maple uses. I understand that some (/many/all) of them may be proprietary and the persons at Waterloo may not want the general public knowing them, but even an answer as simple as "Accelerated Newton-Jacobi algorithm" would be good.
Hi, I have plotted the following chart using maple 10 on windows xp > plot(((x^2)+x-4)/(x-2),x=-4..6,y=-2..10); X being -4, 2 Which command needs to be executed to find the local extremity? Thanks in advance for any help… Robert
Another hour, another possible problem. Consider the following Maple statements:

> f := table([index=m]);
f := table([index = m])
> g := copy(eval(f));
g := table([index = m])
> g[index] := one;
g[index] := one
> h := g;
h := g
> f[index], h[index];
m, one
> g := copy(eval(h));
g := table([index = one])
> g[index] := two;
g[index] := two
> l := g;
l := g
> f[index], h[index], l[index];
m, two, two

So, after the first copy, the second table h has value one for index, while f still has value m for index. Yet, after the second copy, not only the third table l has value two for index, but also the second table h now has value two for index, while I have explicitly used copy to make a copy of h. Does this indicate a problem with the copy function?
Hello,

a colleague just noticed the following (erroneous) behavior in Maple 10 :

> a := Psi(2, 2+2*I);
a := Psi(2, 2 + 2 I)
> printf("%+.6e\n", Re(a));
Error, (in fprintf) number expected for floating point format
> evalb(Im(a) <> 0);
false

The behavior is correct in Maple 9.5 :

> a := Psi(2, 2+2*I);
a := Psi(2, 2 + 2 I)
> printf("%+.6e\n", Re(a));
+3.902435e-02
> evalb(Im(a) <> 0);
true

-- Regards,

Franky.
Yet another question (after scouring the Maple documentation and coming up empty-handed): The following commands: with(student) intercept(y=sin(x), y=0) Result in this output: {y=0, x=0} How can I return the other intercepts with the x-axis? For instance, the first positive and first negative non-zero intercepts? (i.e. the "first" x-intercepts traveling left and right away from the y-axis?) Thanks as always, Bryan
Quick question: in maple , sqrt(4) returns 2. Why not plus/minus 2, since -2 is also a valid square root of 4? Thanks! Bryan
anyone has done significant development with these two?
Additionally to my previous post: First example returns (mathematically) wrong result,
eval(diff(v(z), z), [v = (x->x*H), z = H])
         2H
Equivalent works fine (just because multiplier "a" leads to implicit conversion of diff to D).
eval(diff(v(a*z), z), [v = (x->x*H), z = H, a = 1])
         H
And the most exiting example (I think, that result can't be predicted by Maple developers also ):)))
eval(diff(v(x, y), x, y), {x = H, y = H})
         (D[1,1](v))(H,H)+2 (D[1,2](v))(H,H)+(D[2,2](v))(H,H)
Functional analog works, of course, without any errors.

Create new document (or worksheet) with content below and execute it step by step: > restart; > Eval(diff(v(z),z),z=H)==eval(diff(v(z),z),z=H); Eval(diff(v(z),z),z=H)=diff(v(H),H) > v:=z->z*H; v:=z->z*H > value((1)); H=2H As you can see, result of eval, which in this case is equivalent to subs(z=H,diff(v(z),z)), at the right side of first equation leads to wrong final result :( This...

Where can I find Maple worksheets for viewing/download with regards to the following fields of application?:- 1) soft independent modelling of class analogy (SIMCA), regularized discriminant analysis (RDA) and discriminant analysis with shrunken covariances (DASCO) for multivariate classification, 2) principal component scores-based multivariate statistical process control (MSPC), 3) modelling of multiplicative terms in analysis of variance (ANOVA), 4) generalized rank annihilation method (GRAM) and iterative target transformation factor analysis (ITTFA) for curve resolution and optional second-order bilinear calibration, and
This is regarding an earlier thread about Maple's misleading output of exponentials. Here is a link with a screenshot of what I am talking about: Maple output It seems like no one else is experiencing this problem. Maybe it has something to do with the version of java or OS X I am running, which is OS 10.4.3, Java 1.5, and Maple 10.01.
Try typing the following input in Maple 10.01 in 2D mode (on Mac OS X) input: (e) output: e when in fact what maple means is this: e The intended answer appears when you call simplify on the first result, but this seems dangerously easy to confuse, especially for inexperienced maple users, or if this was returned as the answer to a problem (like taking residues, where I discovered it) it could be easily overlooked -Matt
I'm running Maple 10.01 under Mac OS X ( 10.4.2), and when set my Java Preferences so that the J2SE 5.0 being used in the runtime environment, Maple will not open and gives the following error: Uncaught exception in main method: java.lang.NoClassDefFoundError: org/apache/crimson/parser/XMLReaderImpl Maple works fine for me when the runtime environment is set to use J2SE 1.4.2. -Matt
First 71 72 73 74 75 Page 73 of 75