MapleSim Questions and Posts

These are Posts and Questions associated with the product, MapleSim

Hello everyone,

For some reason, the rising edge block is not working how it is supposed to.

The component decription is as follows: "

The Rising Edge component triggers a Boolean expression, true, in the output, y, when a rising edge is detected at the input, u.

I am applying a step signal. (red waveform)

and this is the probe's measurement:

Why is it not detecting the rising edge?

Thanks,

John.

Hi ,

I have recently got to know this software and its capabilities and was wondering if I can use it to start an initial systems design for an E-scooter as a first step (virtual validation). then feed this data to a designer which will design and cooperate with an engineer to realise the design again on this platform.

SO i have the range of my scooter , the weight it carries , the enviroment's average topography which i will be simplifying it at the first step to a 15% hill climb , and finally some dynamic/static restrictions... which i hope ican build upon . like adding chasis loads and analysis to data.

I want it to give me the cell number of the batteries , verify the loads and give me a electric-motor description . 

 

this was the road map.

 

Thank you for your kind replies .

Hi everyone,

I need to assign the output of the timer block to a variable which is then will be used in a trapeziod signal to add a time offset. Please see the visual below.

Thanks for your time,

Canberk

Hello guys..

I am a master student and I am interested in modelling of six dof industrial robots. in this study, ı firtsly import autocad model into Maplesim and add revolute jont between each  two link. I want to coriolisis matrix from the model with inertia matriix . I wait your helping and thanks for your interest   

What shall I do to install Maple 15 and MapleSym 5 in a Windos 10 environment.

I find the procedure in Maplesoft site up to Windows 8.

May I follow it for Windows 10.

Thank you for any help. Kind regards

Hi,

I get an error when I try to create a modelica block including a piecewise function with one of its expressions including csgn function.

similarly when I use the piecewise And for its conditions.

are these not supported in Modelica?

I  encountered a non-integrable integral in the process of solving the following process, . How to achieve its numerical solution? Such as in a looping   code:

#######
pa[i] := pa[i-1]-(Int(subs(t = tau, Lpa[i-1]+Na1[i-1]-Na2[i-1]), tau = 0 .. t)); 

pw[i] := pw[i-1]-(Int(subs(t = tau, Lpw[i-1]+Nw1[i-1]-Nw2[i-1]), tau = 0 .. t)); u[i] := u[i-1]-(Int(subs(t = tau, Lu[i-1]+Nu1[i-1]+Nu2[i-1]), tau = 0 .. t));

######
Detailed code see annexBC2.mw

Hello every one,

I'm using Maple to create a compiled program of my model Maplesim. I had a error with "getcompiledProc" command, which is :

Error, (in GetCompiledProc) non-numeric initial condition for `Main.RAB.value`(t): Float(undefined)

the "Main.RAB.value(t)" represent a probe used to visualize an output of my system.

Does anybody had a such error ?
Thank you for your responses.

Larbi ANIBA

Hi,

I was playing around with the example "Simple Inverse Kinematic Problem" and found somethings to be odd:

the angular motion seems to be calculated from between pi and negative pi and this has some effects when using position block to move a joint.

the original angular displacement is graph below

the angular displacement after ik calculations have been performed:

if you run the simulation it seems to copy and mirror the input pendulum, however if you disable one of the IK solutions you see that infact its motion isn't like the input.

this becomes more prevailant when you use a position block to force rotation on a joint instead of using the 'prescribed rotation' blocks that comes with the example.

My question then:
why does this happen?
how do I work around this?

the importance that the motion is follow precisely becomes more prevailent when we want to extract other values such as vel, accel, torque. they are incorrect and very jumpy. Also simply put the angular displacement is wrong, how do I fix it?

(side note: I'm thinking  it has to do with the way arctan is calculated in maple limits it to stay in range -pi to pi
"For real arguments x, y, the two-argument function arctan(y, x), computes the principal value of the argument of the complex number x+Iy, so −π < arctan(y,x) ≤ π." from https://www.maplesoft.com/support/help/Maple/view.aspx?path=invtrig)

pjf

Hi,

I am trying to download some MapleSim Robotic models from the Maplesoft website but I have 'Invalid File Format' error. Could you help please?

Best

Onder

Dear forum users/ admins, I have some questions regarding the wind turbine vibrations model based on the MapleSim gallery. I am a new user, went through some tutorials and am currently trying to understand how the system works.

 

I will try to deliver my questions based on the pictures shown below:

 

 

 

 1. After running the model, 2 results were shown. One is "Latest Results" and the other is "zeta=0.01". Based on the images above, there is a comment that the result was dated Feb 14 2013. Is this the result on which the day the model was created? If it is, is it programmed to be in the result file everytime the simulation runs?

 

 

2. If I untick "zeta=0.01", a red graph appears, which says Latest Result. But the graphs are not labelled. How can I label this graph in MapleSim? 

3. I would also like to ask, what type of vibrations are occuring in the model, and what does the Deflection-Time graph means. Why does the deflection occur highest at 120s and then drops? Is it because the tower becomes stabilized after a while?

 

 

4. I understand that the model is run by a signal and fed into a speed component. May I know what is the f(critical) is, and how it affects the system?

 

 

5. From the Ramp signal, there is a "height" value. The pre-set value is 10. After changing this value, to lets say 50, the maximum deflections occur at a an earlier time as shown in the figure below:

 

 

6. I would like to understand how does the ramp affect the maximum deflection time that occurs.

 

Thank you very much!

I have created a model for a robot in Solidworks and have imported it into Maplesim using the CAD toolbox. The problem I have is that the robot has 3 arms that are supposed to come together on a central piece pictured below in figure 1, but attempting to simulate the model with all arms connected with a revolute joint as in figure 2 yields an error that says "The system is underdetermined" the location of the error is main.

For the purposes of the image below I only connected one of the arms, this allows Maplesim to run the file successfully.

figure 1 showing the central piece that the 3 arms are supposed to connect to.

 

Figure 2 showing the problem revolute joints circled in black, the error at the bottom and the setting of the revolute joint on the right.

 

Essentially my question is how do I get the model to work? I apologise if this problem is not terribly well demonstrated, this is my first post onto this forum so I am not sure of all the standards.

Dear MapleSoft,

 

Would it be possible you once design a MapleSim webinar for users with more emphasis on Modelica (language, examples, etc.), on how to build more complex custom components, not just a simple DC motor? I think this would be very useful and could extend / enhance the use of MapleSime even more.

 

Tx in advance,

best regards

 

Andras

you write:

where i can found oscilloscope icon for cisuit simulation?thanks

1 2 3 4 5 6 7 Last Page 2 of 32