MapleSim Questions and Posts

These are Posts and Questions associated with the product, MapleSim

I have recently reinstalled the MapleSim 6.4 but the probe windows do not appeaar anymore.

The image below shows that there are 3 probes (none are disabled) and when I run the simulation nothing happens.,

please help me on check my schmitt2.msim schmitt's trigger 

I have an excel macro file (enable macro or save as macro and run) in which the colour of cells keep changing by a macro named macro2.

Can we achieve it in maple or maple sim?

Any one please suggest a way for me to try out.

COLOR1.xlsx

Thanks.

Ramakrishnan V

I dragged into model space prismatic FixedFrame and RigidBody components and prismatic joint along y axis. I also set mass m = 1 kg. The manual says set K_S = K_S and K_K_d in inspector parameter setting. It did not work out. So i set values 12 and 0.1 for K_S and K_d. I sreated subsystem sub of rigidBody and followed the following instructions,

Quote" PrismaticJoint.PlacethePrismaticjointandRigidBodyinasubsystemcalledsub.Thisallowsthe EquationTemplatetogenerateequationsspecificallyfortheselectedsubsystem.
3. ClickTemplates( )intheMainToolbarandselecttheEquationstemplate. 4. IntheAttachmentfield,provideaworksheetnameandclickCreateAttachment.Your MapleSimmodelopensinaMapleworksheet,withtheSubsystemSelectionwindow.

ClickLoadSelectedSubsystem.Thesubcomponentparameterandvariablesload automaticallyintheParameterandVariableManipulationareas"

After this i wanted to modify the equations. I could not. The same equation is reassigned.

Parameter and variable rows - are as shown in manual, but a blank row not available for user's use. But how do i get the variable x(t) there and rename it?

Thanks for an example of this chapter with an application of its use., if available with anyone?

Ramakrishnan V

Hi, i don't know what happened but every time that I run the simulation appears this: 

invalid input: Multibody:-GetMultibodyData expects its 4th argument, lsProbes, to be of type list(list), but received registerMultibodyVariable

If anyone can solve this problem, I am going to be very grateful. Thanks

Main

Dear All,

This is probably an easy issue to solve.

I have imported an .xls file using the 1D lookup table.

I need the signal to be executed for 4 seconds which is also how long my simulation duration is.

So I set the Ramp height and rise time to 4s. For some reason when I display the signal using a probe it gives me the constant value of the first row of my Excel sheet. I need help to solve this! I have provided some visuals below.

Thank you for your time!

Can

how to design antenna with maple i am looking for designing patch antenna using graphene 

Hello everyone,

For some reason, the rising edge block is not working how it is supposed to.

The component decription is as follows: "

The Rising Edge component triggers a Boolean expression, true, in the output, y, when a rising edge is detected at the input, u.

I am applying a step signal. (red waveform)

and this is the probe's measurement:

Why is it not detecting the rising edge?

Thanks,

John.

Hi ,

I have recently got to know this software and its capabilities and was wondering if I can use it to start an initial systems design for an E-scooter as a first step (virtual validation). then feed this data to a designer which will design and cooperate with an engineer to realise the design again on this platform.

SO i have the range of my scooter , the weight it carries , the enviroment's average topography which i will be simplifying it at the first step to a 15% hill climb , and finally some dynamic/static restrictions... which i hope ican build upon . like adding chasis loads and analysis to data.

I want it to give me the cell number of the batteries , verify the loads and give me a electric-motor description . 

 

this was the road map.

 

Thank you for your kind replies .

Hi everyone,

I need to assign the output of the timer block to a variable which is then will be used in a trapeziod signal to add a time offset. Please see the visual below.

Thanks for your time,

Canberk

Hello guys..

I am a master student and I am interested in modelling of six dof industrial robots. in this study, ı firtsly import autocad model into Maplesim and add revolute jont between each  two link. I want to coriolisis matrix from the model with inertia matriix . I wait your helping and thanks for your interest   

What shall I do to install Maple 15 and MapleSym 5 in a Windos 10 environment.

I find the procedure in Maplesoft site up to Windows 8.

May I follow it for Windows 10.

Thank you for any help. Kind regards

Hi,

I get an error when I try to create a modelica block including a piecewise function with one of its expressions including csgn function.

similarly when I use the piecewise And for its conditions.

are these not supported in Modelica?

I  encountered a non-integrable integral in the process of solving the following process, . How to achieve its numerical solution? Such as in a looping   code:

#######
pa[i] := pa[i-1]-(Int(subs(t = tau, Lpa[i-1]+Na1[i-1]-Na2[i-1]), tau = 0 .. t)); 

pw[i] := pw[i-1]-(Int(subs(t = tau, Lpw[i-1]+Nw1[i-1]-Nw2[i-1]), tau = 0 .. t)); u[i] := u[i-1]-(Int(subs(t = tau, Lu[i-1]+Nu1[i-1]+Nu2[i-1]), tau = 0 .. t));

######
Detailed code see annexBC2.mw

Hello every one,

I'm using Maple to create a compiled program of my model Maplesim. I had a error with "getcompiledProc" command, which is :

Error, (in GetCompiledProc) non-numeric initial condition for `Main.RAB.value`(t): Float(undefined)

the "Main.RAB.value(t)" represent a probe used to visualize an output of my system.

Does anybody had a such error ?
Thank you for your responses.

Larbi ANIBA

1 2 3 4 5 6 7 Last Page 2 of 34