MaplePrimes Questions

HIIIIIIIIIIIIIII! :) I'm doin a problem on the restricted 3 body problem...What i want is to creat a proc "equilibria(mu)" which finds all five equilibria of (DE) when mu_1=mu and displays, in a neat table, the (x,y)-position of each equilibrium and the eigenvalues of the vector field's Jacobian at that equilibrium. In addition, the table should indicate if the equilibrium is hyperbolic (all eigenvalues are real and non-zero), elliptic (all eigenvalues are imaginary and non-zero), hyperbolic-elliptic (a mixture of non-zero real and imaginary eigenvalues), or otherwise.. Now the difficulty is this, i can find the equ's and get the evalues, but i have a proble with gettin them into a table...i've been told that prinf is a good one to use, but i have no idea at which bit to use it..this is how far i've got
When I plot y = (x^2 + 5x + 6)/(x^2 - 4)... where's the hole? That is, Maple provides the vertical asymptote when using the Student Tools-Precalculus library but why not the hole? Thanks, C.
Hello, I am in doubt with the following situation. It started with this: > f := signum(z)*infinity; > type(f,complex(extended_numeric)); # false > is(f,complex(extended_numeric)); # false Now I make an extra assumption on z, and do these checks again: > assume(z,real); > type(f,complex(extended_numeric)); # false > is(f,complex(extended_numeric)); # true I was wondering why the second time is results in true while type does not... I am just checking whether the expressions is an infinity (possibly in complex form), and so I don't see where the difference could come from.
Hi, I just bought Maple, and I'm really excited about it. I'm poking around in Maple, trying to get comfortable with it, by entering in a problem from my physics class. In this class, we use SI units, except that we express our angles in degrees. I'm trying to find an easy way to have the trigonometric functions take degree arguments. I tried "with(Units); with(Units[Natural])", and entered an expression this way: "R_x = R*sin(15*deg)", and that almost worked. There were two problems, though: 1. R is apparently a unit in its own right...not *too* much of a problem (I can choose another letter), but annoying.
I feel a bit stupid asking this to be honest.. Here goes anyway.. I'm an 'early learner' regards math (certainly not early of years though :) and have recently taken a very keen interest in the physical sciences and wish to improve my math skills in order to allow me to explore ideas in this area. I have been looking for a PC based math package 'of some description?'that will allow me to interactively try out ideas and will give good visual feedback, graphing etc; I'd also like this 'study tool' to be comprehensive enough that it will not hinder me (probably through my clumsiness in honesty) and that has a very intuitive interface (ie, not overly strict with syntax and rules).
I just recently learned that the fourth operand of a maple procedure is it's memory table. However, I'm confused about being able to identify the other operands, primarily the first three, if I was to see a written procedure for example and determine what they are. For example is the first operand the argument used in the procedure ? The 2nd argument, any local or global declared variables ? The 3rd argument, any option settings ? Also if the procedure body is basically instructions for the procedure, then what is the description part of a procedure definition ? Da
How do i format numbers in maple output including comma separation and number of decimal points, etc (i.e. 33,444.00)
I'm having some problems with my uni Maple test questions. How do I after creating a partial fraction expansion extract the numerator of the 5th summand in the par frac expansion using a maple command? Also using the geom3d package, how do I set a line using the 'parallel' command which goes through a point and is parallel to another point? (x,y,z) Thanks in advance.
I want to produce a table of values with a heading. I’d like something like a heading with the name “x
In order to generate a 2x2-matrix in the question text I use
$display_matrix =maple("printf(MathML:-ExportPresentation(<<($a),($c)>|<($c),($b)>>))");
where $a, $b, $c are random numbers (see below for full question source).

In MapleTA 2.0.1 the question operates correctly. I quote here an exemplatory call to Maple taken from the console:

jvm 1 | To Maple --> printf(MathML:-ExportPresentation(<<(-4),(6^(1/2))>|<(

However, instead of depicting the corresponding matrix, MapleTA 2.5 depicts the Maple code. That this will happen can also clearly be seen in the call to Maple:

jvm 1 | To Maple --> printf("%m", 'Matrix(2,2,{(1, 1) = -2, (1, 2) = 2*2^(1
/2), (2, 1) = 2*2^(1/2), (2, 2) = -4},datatype = anything,storage = rectangular,
order = Fortran_order,shape = [])');

How does it come that MapleTA 2.5 decides to add "%m" to printf? Is there a possibility to fix this by making appropriate changes in a setup file?

I would be grateful for any hint.

Full question source (the question asks for the eigenvalues of the shown matrix):

mode=Multi Formula@
name=eigenvalues (more ergonomic)@
algorithm=$case = range(1,3);
$c = maple("[sqrt(6),sqrt(8),2][$case]");
$sign = range(-1,1,2);
$b = range(-5,5);
$a = $b+($sign)*($case);
$display_matrix = maple("printf(MathML:-ExportPresentation(<<($a),($c)>|<($c),($b)>>))");
question=Bestimmen Sie die Eigenwerte von $display_matrix.
I've just gotten started with maple (2 days ago). I needed to construct a set whose elements are vectors. During the generation of these vectors, there turn out to be duplicates and I was hoping that the set union operation will get rid of these. Instead, I end up with a set consisting of duplicated vectors. Here is a very simplified case that my problem boils down to: with(LinearAlgebra); a:=UnitVector(1,2); b:=UnitVector(1,2); #a and b are clearly equal. s:={a,b}; #s should be just the singleton set. But it gives s as being a 2 element set with this vector repeated.
While using Maple 10 at school I ran into an error when trying to plot a spacecurve within a 3D plot. When I enter: > A:=spacecurve([2*x,0,0],t=0..1); I get: A := PLOT3D(CURVES([[undefined,undefined,undefined],[undefined,undefined,undefined].. That take up half the screen. If I try to plot this, there is no curve on the plot, but I can see the axes. WinXP SP2 1024Mb RAM (I think) Nvidia Ti-4200

I want to ask about a small problem. I will present a paper at a conference in February. Because it involves time consuming calculations of numerical solutions for several onerous systems, I will do the calculations at home before the talk, save the results, and show the output to the conference. The folks attending the conference are not necessarily Maple Folks, so I do not want to have to explain the tilde after characters for which I have made assumptions. Of course, I know about


After making the calculations here at home, traveling to the meeting, opening the file to make the presentation then, alas, the tildes are back again. Try this.

> assume(a, real):
> interface(showassumed=0):
> equa:=a^2+a-1;

Run this file. No tilde. Close the file saving the output. Open the file. There is the tilde after each “a".

My question:is there some way to make the tilde stay gone when I save such a file and reopen it without recalculation the worksheet?

Does anyone know how to use the Maple workheet "Mma" which is supposed to translate Mathematica notebooks into Maple? I got Mma from the Maple site ( Is appears easy. Initialize the process with the commands interface(warnlevel=0): interface(displayprecision=4): with( MmaTranslator ): The give the tranlator the location of the Mathematica notebook with FromMmaNotebook( "C:/Notebooks/mmaSampler.nb" ); Even though I've checked the Matematica notebook for accuracy, All I ever get are error messages.
Hi all, I'm a new user'll forgive me if I've chosen the wrong forum. That's my problem: I've used Maple 10 3 or 4 times since the installation, but the last time I've tried to start it, the window was completely GRAY; after about a minute an error message appeared saying something about a 'peripheral error' and 'restart the computer to restore the system' (...sorry for bad translation from italian), the interesting thing is that the system has changed its graphical settings about the monitor resolution (800*600) and colors (I think 4 or 16). An other information... I noticed that a txt file was created just in that time and placed into maple directory: 'hs_err_pid1136.txt'; opening it you can read 'An unexpected exception has been detected in native code outside the VM.
First 2279 2280 2281 2282 2283 2284 2285 Last Page 2281 of 2301