MaplePrimes Questions

I have a problem in my document ( with the following four lines of code

maplet3 := Maplet(MessageDialog(warning, "No file containing dissociation constants found.", 'onapprove' = Shutdown()));

Attached are two documents.  The first contains just the lines above and works fine.  The second generates an error when run if you choose No to both dialogs, and the error appears to be with the same four lines of code (if I comment those lines I do not get an error).

Please help! How to solve this?


I was wondering if it was possible for maple to automatically type in the values of the variables when calculating like




instead of just typing


hope my question makes sense :D

Let x, y, z be nonnegative real numbers. Obviously, x3+y3+z3-4xyz is not always nonnegative, since its value is -1 when x=y=z=1. But why Maple's minimize gives wrong result? 

minimize(x^3 + y^3 + z^3 - 4*x*y*z, x = 0 .. infinity, y = 0 .. infinity, z = 0 .. infinity);

Attachment: MinValue.mws.

MMA's Minimize finds correct infimum: 
So, can Maple always find correct exact (i.e., not just numerical) global minima (or maxima) at least for such problems with a small number of variables as well?

When you use

diff(x(t), t)

the output is $\dot{x}(t)$
When you write 

diff(x, t)

the output is $\frac{\partial}{\partiall t} x$

Is it possible to "mix" these two in such a way that diff(x, t) appears as $\dot{x}$ ?

Thanks in advance

Wanted to plot a vector with the arrow function

for some reason the arrow head was not created. tried changing the input so the resulting coordinat would be [10,10] insted of [725,350] this created an arrowhead on the line.

l1 := arrow([0, 0], [725, 350], 0.1, 0.4, 0.1, arrow, color = red, legend = "Vector v");
display(l1, axes = frame, view = [0 .. 900, 0 .. 500]);

Why does it not create the arrow head happen???

Either I am clueless (or very tired) or StringTools:-Remove is not behaving as it should (document attached)

Suppose a have a file "test.txt" with the following single line of code (intentionally missing the "end if"):

When I run "maple test.txt" from the command line, it shows the following and quits:

> if x = 1 then print("hi");
> quit
> quit
on line 3 of "test.txt", syntax error, reserved words `quit`, `done`, or `stop` unexpected
> quit

But it quits with exit code 0, despite the syntax error. Is there a way to get Maple to quit with a nonzero exit code when there is a syntax error?

What I would actually like is that if Maple encounters any error at all (syntax or otherwise), the script immediately ceases execution and exits with a nonzero error code. When the error is NOT a syntax error, I can at least accomplish this by wrapping the entire script in a try/catch block. But I'm hoping there's a better way.

Not the first time that a question (OP's name  PhearunSeng ) is removed as I am writing an answer (I guess other people have already faced the same inconvenience). 
Why doesn't exist a mechanism which prevents removing, deleting, displacing a question where someone (here Carl) has akready given an answer ???

Whatever the reason, here is my answer

Title: Can be done quickly if you write the matrix in a more abstract form

MyKGff := Matrix(5, 5, 
    (1, 1) = A+(1/63368)*B, 
    (1, 2) = -(1/63368)*B, 
    (1, 3) = -(1/39605)*B, 
    (1, 4) = 0, 
    (1, 5) = 0, 
    (2, 1) = -(1/63368)*B, 
    (2, 2) = (1/63368)*B+C, 
    (2, 3) = (1/39605)*B, 
    (2, 4) = -C, 
    (2, 5) = 0, 
    (3, 1) = -(1/39605)*B, 
    (3, 2) = (1/39605)*B, 
    (3, 3) = (8/198025)*B, 
    (3, 4) = 0, 
    (3, 5) = 0, 
    (4, 1) = 0, 
    (4, 2) = -C, 
    (4, 3) = 0, 
    (4, 4) = C+(1/63368)*F, 
    (4, 5) = -(1/39605)*F, 
    (5, 1) = 0, 
    (5, 2) = 0, 
    (5, 3) = 0, 
    (5, 4) = -(1/39605)*F, 
    (5, 5) = (8/198025)*F

Then (Maple 2015.2)

PseudoInverse := CodeTools:-Usage( LinearAlgebra:-MatrixInverse(MyKGff, method=pseudo) ):
memory used=28.38MiB, alloc change=68.00MiB, cpu time=312.00ms, real time=314.00ms, gc time=24.90ms

To recover the pseudo inverse with original data do

Rewrite := [
             A = (D__pile*W[1] . E__c)/3000, 
             B = (D__pile*W[2] . E__c)*89^(1/2), 
             C = (D__pile*W[3] . E__c)/1000, 
             F = (D__pile*W[4] . E__c)*89^(1/2)

eval(PseudoInverse, Rewrite):

I would like to be able to use python's matplotlib from Maple. I am doing the following currently

Start('home' = "/opt/anaconda3/lib/python3.9", 'path' = "/opt/anaconda3/lib/python3.9/site-packages")
ImportModule("matplotlib as mpl")

and the error I get back is

Error, (in Python:-ImportModule) ModuleNotFoundError: No module named 'matplotlib'
['Traceback (most recent call last):\n', '  File "<string>", line 1, in <module>\n', "ModuleNotFoundError: No module named 'matplotlib'\n"]

The string I passed into path is the directory where matplotlib seems to be located as far as I can tell. I looked this up in my IDE Spyder, but using the command print(matplotlib__file__).

UPDATE: but actually if I open a new worksheet and execute 

Start('home' = "/opt/anaconda3/lib/python3.9", 'path' = "/opt/anaconda3/lib/python3.9/site-packages")

The error is that 

Error, (in Python:-Start) unable to start Python: could not create process, mpython

So Maple isn't finding Python apparently.

I tried for 'home' also "/opt/anaconda3/bin", did not work.

Hello guys.

How to determine the gradient of the following vector field below:



SetCoordinates('cylindrical'[r, theta, z]):

V:=VectorField(<omega*r, 0, z*r>)

Gradient(V, [r, theta, z]);

Error, invalid input: too many and/or wrong type of arguments passed to Student:-VectorCalculus:-Gradient; first unused argument is Vector(3, [omega*r,0,z*r], attributes = [vectorfield, coords = cylindrical[r,theta,z]])



Working with a Document, I have a procedure which plots a graph and part of the procedure code looks like this:

A := Array(1)
A := plot(...plots two series...):

The first time the procedure is called everything is as expected.  The second time the procedure is called (with different values to be plotted), the graph is not updated and therefore does not reflect the changed data

I am thinking that maybe, each time I call the procedure, I need to somehow "reset" or "release" something at the beginning of the procedure so that the plot is recreated? 

I was working on a document to which I had made some changes which had not been saved.  When running Evaluate Worksheet I had to end the task because I couldn't stop the evaluation.  On re-opening the document my changes were lost, not surprisingly.

Does Maple keep any temporary files anywhere from which I might be able to salvage my changes?

Hello guys.
Is there any way to frame the styles: Input 2D, Output 2D and Text?



I am collecting my coefficients with the below code. Since it is a huge data, i just give a some partion. So I want to write u11 to a text file. But when i use this command  save u11, "u111.txt" . It is writing to text but with big blanks. I show you at the below picture. So when i put it to matlab, it is again with spaces and matlab giving errors. So how can i save my long symbolic output (you can see in picture)  to a text file without spaces. I used 

fd := "C:/double/u11.txt"

fprintf(fd, "%s", u11)


But it did not work. So if you could help me, i really appreciate. My best regards. 

1 2 3 4 5 6 7 Last Page 1 of 2177