okokoabraham

20 Reputation

One Badge

0 years, 173 days

MaplePrimes Activity


These are questions asked by okokoabraham

Hello everyone,

I am presently carrying out some computation of which I intend to solve some equations and get the preceeding values. But it would appear that my maple software just keeps showing evaluating without actually producing any results for hours even days. Is this due to my low laptop specs? 

I would love if the community can take a look at the code, and possibly run it to see if it's ok. I have attached the code for reference. 

Thank you.

 


test.mw

 

Hi, everyone, here is my maple code

 

restart;
In := 5.75*10^(-12);             
M := 1000;

E := 10^12;

V := 100;

m := 2300;

K := 10^9;

A := E*In;
B := M*V^2;

C := 2*M*V^2;

F := M + m;

G := K;
pde := A*diff(w(x, t), x $ 4) + B*diff(w(x, t), x $ 2) + C*diff(w(x, t), x, t) + F*diff(w(x, t), t $ 2) + G*w(x, t);
tmax := 0.05;
xmin := 0;
L := 1;
bc := w(0, t) = 0, w(L, t) = 0, D[1, 1](w)(0, t) = 0, D[1, 1](w)(L, t) = 0;

ic := w(x, 0) = 0

pdsA := pdsolve(pde, eval({bc, ic}, L = 1), numeric, spacestep = 0.01)

 

 

 

I keep getting error message: Error, (in pdsolve/numeric/par_hyp) Incorrect number of initial conditions, expected 2, got 1

but when i change the pde to:

pde := A*diff(w(x, t), x $ 4) + B*diff(w(x, t), x $ 2) + C*diff(w(x, t), x, t) + F*diff(w(x, t), t) + G*w(x, t);

it works, although that is not what i am aiming for at all.

how may i solve this? my goal is to find w(x,t)

Page 1 of 1