omegayen

29 Reputation

2 Badges

10 years, 129 days

MaplePrimes Activity


These are replies submitted by omegayen

Thanks for the reply.

I could not get any speed improvement with my code...

I was able to however use the simple example here http://www.maplesoft.com/support/help/view.aspx?path=TaskProgrammingModel

and observe that CPU usage was nearly 100% while running

 

Thanks for the reply.

I could not get any speed improvement with my code...

I was able to however use the simple example here http://www.maplesoft.com/support/help/view.aspx?path=TaskProgrammingModel

and observe that CPU usage was nearly 100% while running

 

Well when I use both those commands both show up as '4'

I looked into Intel MKL BLAS being compatible with AMD and it says it is on the website  http://software.intel.com/en-us/articles/intel-math-kernel-library-intel-mkl-can-i-use-intel-mkl-on-amd-cpu/

But yeah tried restart as well and still doesn really use more than 25% CPU when running above code I posted originally.... thanks for the help though

Well when I use both those commands both show up as '4'

I looked into Intel MKL BLAS being compatible with AMD and it says it is on the website  http://software.intel.com/en-us/articles/intel-math-kernel-library-intel-mkl-can-i-use-intel-mkl-on-amd-cpu/

But yeah tried restart as well and still doesn really use more than 25% CPU when running above code I posted originally.... thanks for the help though

I went to the control panel, then system, then advanced, then environmental variables and added OMP_NUM_THREADS with a value of 4.... (Windows)... then ran the code again, but still do not notice CPU usage much more than 25%..... anyone else? thanks

I went to the control panel, then system, then advanced, then environmental variables and added OMP_NUM_THREADS with a value of 4.... (Windows)... then ran the code again, but still do not notice CPU usage much more than 25%..... anyone else? thanks

Page 1 of 1