Question: How do you change the font size of labels on axes

In the above Maple document, I present a puzzling problem:  When I use plot3d, the options

font = [Times, bold, 16], labels = ['u', 'v', 'z'], labelfont = [Times, bold, 40] in the command

plot3d([u*sin(2*v), u^2, u*cos(2*v)], transparency = 0.60, shading = none, font = [Times, bold, 16], labels = ['u', 'v', 'z'], labelfont = [Times, bold, 40], grid = [60, 60]);

produces nice big labels on the axes, which are visible as opposed to the almost invisible default size, especially on printouts but when I use these options as in below command:

fieldplot3d([0, 0, -y], x = -2 .. 2, y = -2 .. 2, z = -2 .. 2, arrows = `3-D`, fieldstrength = maximal(0.5), font = [Times, bold, 16], labels = ['x', 'y', 'z'], labelfont = [Times, bold, 40], grid = [4, 4, 4])

the lables x, y and z on the fieldplot are small, the default.  I used the same option and get different results.

I have been researching this for almost 2 hours and I can't find a way to increase the font size in the fieldplot command.

Is this a bug or does the fieldplot command not use these options the way it is used in the plot3d command?

Thank You for reading my question. (I am relatively inexperienced with Maple.)

Tom K.

Please Wait...