Tim Vrablik

629 Reputation

13 Badges

12 years, 316 days

I work in Maplesoft’s Applications group. This group is a hub between Sales/Marketing and R&D. I primarily work with customers to help them use our software for their projects.

Born and raised in Windsor, Ontario, I spent a substantial chunk of my life there. I attended the University of Windsor to study Engineering and Math, and moved to Waterloo to start working with Maplesoft.

My first introduction to Maple was in a differential equations class. Our professor swore by it every day, and felt obliged to show us examples on how to use it at the end of every class. Admittedly, I usually skipped out of class right around that point. It wasn’t until I sat down and used the software to do my homework that I truly realized how useful Maple was…I only wish I had heeded my professor’s advice in the first month of the semester instead of the last.

MaplePrimes Activity


These are replies submitted by Tim Vrablik

@hirnyk to be honest, I didn't know much of this option until a month or so ago when I had a similar error that came up. It's in the help pages listed in the warning, but for some reason the link that was generated in your post above points to the wrong page, it should have pointed here. In Maple 14.5 & 15 it seems to point to the right pages though...odd.

@hirnyk to be honest, I didn't know much of this option until a month or so ago when I had a similar error that came up. It's in the help pages listed in the warning, but for some reason the link that was generated in your post above points to the wrong page, it should have pointed here. In Maple 14.5 & 15 it seems to point to the right pages though...odd.

To avoid getting the warning/error:

eq := y(x)*(diff(y(x), x))+2*b*y(x)*abs(y(x))+k^2*x = 0

sol := dsolve({eq, y(0) = 1}, y(x), numeric, parameters = [b, k])

sol(parameters = [1, 1])

sol(.2)

          [x = 0.2, y(x) = 0.6466553874789345]


To avoid getting the warning/error:

eq := y(x)*(diff(y(x), x))+2*b*y(x)*abs(y(x))+k^2*x = 0

sol := dsolve({eq, y(0) = 1}, y(x), numeric, parameters = [b, k])

sol(parameters = [1, 1])

sol(.2)

          [x = 0.2, y(x) = 0.6466553874789345]


@kmadkins 

First off, the columns were not equal in size. The third column seems to be missing a data point (the first three entries are 1, 1, nothing). I also had converted the data set to a tab delimited txt file via excel. Lastly, I removed some of the conditions in my command (the source=csv part since it is not a csv file). Once I did this, everything worked fine for me. I've attached the updated data file.

Let me know if this works for you now.

sincos3new.txt

@kmadkins 

First off, the columns were not equal in size. The third column seems to be missing a data point (the first three entries are 1, 1, nothing). I also had converted the data set to a tab delimited txt file via excel. Lastly, I removed some of the conditions in my command (the source=csv part since it is not a csv file). Once I did this, everything worked fine for me. I've attached the updated data file.

Let me know if this works for you now.

sincos3new.txt

@kmadkins 

Would you be able to upload your data set?

@kmadkins 

Would you be able to upload your data set?

There were no new blocks added with the point release, but we are planning on adding more components in our future releases. For the time being, you can use the random data template.

I copied your code into a worksheet and got 0 as well, this is because of the diff(A,x) statement that you have entered. If you remove that, B will be def as the matrix, then if you multiply it by some scalar/function/etc, then it should work (at least it did on my computer). Is this what you're expecting?

(1)

(2)

(3)

(4)

(5)

(6)



Download test.mw

I copied your code into a worksheet and got 0 as well, this is because of the diff(A,x) statement that you have entered. If you remove that, B will be def as the matrix, then if you multiply it by some scalar/function/etc, then it should work (at least it did on my computer). Is this what you're expecting?

(1)

(2)

(3)

(4)

(5)

(6)



Download test.mw

If you could supply the model, I might be able to help you with your problem.

Could you upload the model...it would help in diagnosing the problem.

@dkhramov 

Sorry about that. I created this model using V4, although the same procedure should work in V2. Here are a couple of images of the model and the paramters for the rigid body frame.

@dkhramov 

Sorry about that. I created this model using V4, although the same procedure should work in V2. Here are a couple of images of the model and the paramters for the rigid body frame.

1 2 3 4 5 Page 1 of 5