TomM

279 Reputation

8 Badges

16 years, 177 days

Professor of Economics SUNY Stony Brook I use Maple for Research: To test theoretical modelling ideas with various kinds of general equilibrium deterministic and stochastic models in Macroeconomics and Urban Economics. Graduate classes: In Macroeconomics and Econometric classes. Undergraduate classes: In Urban Economics and Computational Methods classes. Note: You can communicate with me in German and French as well as English.

MaplePrimes Activity


These are questions asked by TomM

When I use the Determinant function on a matrix with (single variable) polynomial entries with real coefficients I often get an incorrect answer. I know the answers are incorrect because they have a higher degree or a lower lowest degree than is possible given the matrix elements.

However, when I replace the coefficients in the polynomials with rational numbers or I put in the option method=minor, I get the correct answer.

The problem seems to be roundoff error. However, the important error is not simply small changes in the resulting polynomial. The important error is the presence of entirely incorrect powers of the variable and not with very small coefficients.

How does this happen and why does the help page for Determinant( ) not warn of this behavior? In particuiar, why does the help page not say that using Gaussian elimination (i.e., the default) will often give incorrect answers in such cases, but using method=minor will work? Is this behavior known? I cannot find any reference to it on the internet.

I set up a worksheet with embedded components in Maple 18. I am now trying to use the worksheet with Maple 2015. The GetProperty( ) procedure in DocumentTools cannot find a number of kinds of the embedded components (perhaps all kinds).

Why would this happen, and how can I fix it?

If I store plot directions in a name, the output of that assignment is, annoyingly, a thumbnail plot. Without a way to turn that behavior off, it takes up space and is annoying. However, even more annoying is the fact that, if one enters the plot name alone in a succeeding statement in the same execution group, the plot is produced only as a thumbnail. To produce a standard size plot one has to use display(  ) along with an explicit size parameter.

Strangely enough, if the plot name alone is used in a separate execution group, a normal size plot is produced.

Is there no way to control these annoying behaviors globally?

(1) I keep trying to enter a reply, and it just never appears. What's wrong?

(2) How do I get code from the Standard GUI to paste into a reply?

When I print a Table with graphs in it, the graphs are compressed vertically to an extreme extent. There has to be some compression from the screen, of course, since I have a wide-screen (although the actual worksheet does not use the whole screen width because of the palette and the fact that I don't use full-screen mode. However, the vertical compression  (that is, in a direction where there is plenty of room on the page) is many times more than the horizontal compression. In order to get the printed graph to look normal, I have to stretch the screen graph vertically an extreme amount, which, of course, looks horribly distorted on the screen.

Also when printing a graph as part of a Table, the graph area is clipped so that the title and legend do not print.

I thought that the Table struction would be a good way to display related graphs. But this behavior is making the use of Tables tedious and much less satisfactory because of the missing titles and legends.

None of these things happen when I print a graph in a regular execution group outside a Table structure.

Has anybody else had this problem, and have you found a way to avoid the compression and get the legends?

1 2 3 4 Page 1 of 4