MaplePrimes Questions

Hi, I have numerous terms all of the type opl[i]:= ... with i an integer . Now I want to calculate the total sum of all these terms. I've already worked with a commando like: "for i from 1 to 4 do opl[i]:=... end do;" but I can't find a way to make the sum of multiple terms. By the way is there a site of a good handbook where I could learn more about programming in Maple and make animated curves or objects?

The attached Maple10 worksheet solves a system of differential equations. A plot of the solutions y1(t) (red curve) and y2(t) (green curve) appears below. Download 2353_fsolve-avoid.mws
View file details As a check, I want to use fsolve and the "avoid" option to find both times at which y1 has the same value as when y1=y2, but I'm having trouble. I would appreciate any advice on how I can get the "avoid" option to work for me. fsolve finds the earlier time easily enough (t=.9036852930e-1), but when I use the "avoid" option (highlighted statement below) to find the later time (t=.5225499740), I get the error "Error, (in fsolve) avoid = {.9036852930e-1} is an invalid option." The code is appended below. Thanks. Glenn ======== > restart; > with(plots): > sys:= Diff(y1(t),t)=-3*y1(t) + 2*y2(t), Diff(y2(t),t)=y1(t)-3*y2(t); > ic := y1(0)=1, y2(0)=5; d d sys := -- y1(t) = -3 y1(t) + 2 y2(t), -- y2(t) = y1(t) - 3 y2(t) dt dt ic := y1(0) = 1, y2(0) = 5 > odesol:=dsolve({sys,ic},{y1(t),y2(t)},type=numeric,output=listprocedure); odesol := [t = (proc(t) ... end proc), y1(t) = (proc(t) ... end proc), y2(t) = (proc(t) ... end proc)] > Y1:=eval(y1(t),odesol); Y2:=eval(y2(t),odesol); Y1 := proc(t) ... end proc Y2 := proc(t) ... end proc > Teq:=fsolve('Y1'(t)='Y2'(t),t); Teq := 0.5225499740 > Yeq:=Y1(Teq); Y2(Teq); Yeq := 1.45974175440983366 1.45974175447049736 > T1:=fsolve('Y1'(t)=Yeq); T2:=fsolve('Y2'(t)=Yeq); T1 := 0.09036852930 T2 := 0.5225499740 > fsolve('Y1'(t)=Yeq, t, avoid={T1}); fsolve('Y1'(t)=Yeq, t=T2); Error, (in fsolve) avoid = {.9036852930e-1} is an invalid option 0.5225499740 > Y1(%); 1.45974175440983366 > plot({Y1(t),Y2(t)},t=0..3);

I am relatively new to Maple, and have been attmpting to solve this for the last few days, and if somebody would be able to help me out that would be great. I am attempting to make the list of following equations smooth (supposed to be for a roller coaster): u(x)=.8x (where x is less than 0) g(x)=kx^3 + lx^2 + mx + n (where is is greater than or equal to 0 but less than 10) f(x)=ax^2 + bx + c (where x is greater than or equal to 10 but less than or equal to 90) h(x)=px^3 + qx^2 + rx + s (where x is less than 90 but greater than or equal to 100) t(x)=-1.6x + 120 (where x is greater than 100)
how do i determine the coefficient of determination?
i am trying to find a regression plot for "n" data points with a degree of "n-1" but maple gives me this: Warning, there are zero degrees of freedom a regression curve with that degree should have a r^2 = 1. this regression curve is possible on my ti 83, but not in maple. how do i get it to work in maple?
How can I display one (or more) point using plot? E.g. How can I plot the following ycoord vector: [1,2,5,4,3] (xcoord=[1,2,3,4,5])? In the maple help it was discussing function plotting only...
I have a procedure with multiple outputs and one input -- how do I make a 2D plot of these outputs as a function of the input (i.e. a plot with multiple curves)? I have tried using single quotes and the -> operator in various combinations, to no avail. For example, say my procedure is: solset2:=proc(k) local eqn1,x; eqn1:=x^2+k=3; fsolve(eqn1,x) end proc; The following does not work: plot('[solset2(z)]',z=-1..1); I realize there are lexical scoping issues here, but I don't understand the subtleties...
With Maple 11, the 2-D editor has become greatly more reliable. So now I am trying Document Mode for the first time. My question is this: what disadvantages does Document Mode have compared with (Standard) Worksheet Mode? I.e. given that 2-D input is being used, why would someone use Worksheet Mode instead of Document Mode?
A user in Ireland is trying to learn Maple programming, and got stuck on trying to reproduce the examples on p.49 of the Introductory Programming Guide. First, I suspected it might have had to do with 2D mode (it doesn't, it works on Windows), so I asked him to try in the TTY version. The results there were really weird: 130_Picture_8.png What could be the problem? Is this Mac-only? Is this some locale issue?
I have four column vectors of data points; X1,Y1,X2,Y2 (n=30) where pointA is given by (X1[n],Y1[n]) and pointB by (X2[n],Y2[n]) I can plot lines using indvidual rows with n=rownumber plot([ [X1[n],Y1[n]],[X2[n],Y2[n]] ]) However, I want to animate the plot so it shows n=1, then n=2 and etc. I am aware of the "insequence" option but I don't want to have to write the 30 entries into a "display" command. Any tips
I have four column vectors of data points; X1,Y1,X2,Y2 (n=30) where point1 is given by (X1[n],Y1[n]) and point2 by (X2[n],Y2[n]) I can plot lines using indvidual rows with n=rownumber plot([ [X1[n],Y1[n]],[X2[n],Y2[n]] ]) However, I want to animate the plot so it shows n=1, then n=2 and etc. I am aware of the "insequence" option but I don't want to have to write the 30 entries into a "display" command. Any tips
Using the formula: ((A/B)^(3/2)*(C*D*E/F*G*H)/(I/J)^(3/2)*(K*L*M/N*O*P) I have a different list of [a1,a2....a11] for each variable except A,B,I,J which are constants. I've seen examples for using a single list, but never for using multiple lists. There are 11 numbers in each list, so I should get 11 answers. Thanks for the help. Will
I am trying to read from a embedded MathContainer a simple expression. I am using the expression func:=parse(GetProperty('MathContainer0', value)); When I execute the above code I get the error, "incorrect syntax in parse: missing operator or ';' (12)". I have read over the help pages on MathContainer, GetProperty, and parse to no help. The syntax looks fine to me. The parse help page did indicate that MathML may be reponsible, but the MathML help page was no help. What is the syntax error that is occuring? The expression works fine if I use func:=parse(GetProperty('TextArea0', value));
Hi Guys I just started learning Maple and I have basic question which is annoying me. I use Maple 10 and when I execute the following statement I get the final result as the output instead of a set of numbers. for i from 6 by 2 to 15 do print(i) end do; 14 what am I doing wrong? Am I missing something here? I tried searching all over but could not find a solution. Help is very much appreciated. Thx in advance
I have a situation which is not really complicated but it would be awkward to explain it in a text post, so I have described it in the attached worksheet. It has to do with the display of matrices. If anyone has the time to take a look at the worksheet and propose a solution I would be grateful. -Thanks View 2292_Matrix Display.mw on MapleNet or Download 2292_Matrix Display.mw
View file details
First 1828 1829 1830 1831 1832 1833 1834 Last Page 1830 of 1916