ivar_kjelberg

61 Reputation

5 Badges

14 years, 255 days
My current post is "Senior Expert" with 30+ years of experience in mechatronics developments in the frame of complex, multidisciplinary, high tech "systems engineering" activities. Previous posts were "Senior Project Manager, Section Head, Project Manager, Quality Engineer, R&D Engineer. I work in a retained profit company, a "High Tech", R&D Institution, closely linked to the EPFL (Ecole Polytechnique Federale de Lausanne), we are located in Neuchatel Switzerland. We use advanced tools such as Maple, MapleSim and COMSOL Multiphyiscs for our developments and for our Ph.D. training activities.

MaplePrimes Activity


These are questions asked by ivar_kjelberg

Hi simulators

Is there an easy way to give a global time frame/limits for all plots: typically I need to simulate a few seconds to get rid of all my transients, and then I would like to zoom in on the effect of interest. Now I have only found out how to reset one by one each graph via the axis properties, I have a dozen graphs per simulation 4 variables to scan over ten points each, that makes a damn lot of graphs properties click to reset, results: I need 60 sec to...

Hello

I wanted to vary my mass item in MapleSim5, to have it appear and dissapear. I noted I could us the variable "1*t" [kg] in a rigid body mass item, that worked out fine

Then I wanted to have a force variable depending on the time, but now I get a message Main.t is not defined in Main

So finally how to refer correctly to the "time" ?

 

Subdiary question: how to use signal blocks to generate a named variable that I use elswhere in my model for a Parameter input

Dear all,

I'm stuck here with a parameter passing issue, I understand that the parameters I define are global to all items "below", incuding nested subsystems, this seems logical and works nicely in MapleSim.

Dear all

I get a nasty message when trying to "Analys" a module representing some hardware with an analog output clipping signal (standard MapleSim block): " ...cannot create DynamicSystems with Model that consists of bolean equations ..."

Hello

Does anybody hasa suggest how to quickly get the "initial conditons" of a (control) loop in MapleSim ?

When I'm debugging loops in MaplSim I'm missing a way to get the inital conditions and then to be able to see the (first) numerical values in each probe or on the "wires/ports".

Does something like this exit, or is it to be pushed on the "suggestion" list.

This applies also to PDE resolutions, the "get Initial Condition" run is a good trick to first check your model before running it.

1 2 3 Page 2 of 3