MaplePrimes Questions

Please, l need assistance on maplesoft activation code 

 

Hi, 

How can I determine an expression is of the form a*b where a is anything but a function of t, and b a function of t?
I thought I could do this using patmatch but I can't make it work correctly.

For instance I would like patmatch (or something else) to return [a=C, f=F] when called this way patmatch(C*F(t), ?)

Thanks in advance

I'm trying to arrange the constant terms of W(x). Like sinh (alpha*x) *(C2-C1).....and by defining C2-C1= D2 I want to rearrange the equation. Without this step, I'm not able to solve the equation further. I have also tried a few steps but it's not working.

When I type "with(combinat)" in Maple Linux, I got the following erros message:

"Error, invalid input: with expects its 1st argument, pname, to be of type {`module`, package}, but received combinat"

So how to make it work? 

 

Many thanks.

Could anyone show me the exact command lines or exact steps to install the FGb package, specifically FGb-1.68.x86_64_linux.tar.gz here, to Maple 2020 in Linux Ubuntu? Many thanks.

FYI, here is one of the error messages I got: 

"mv <14539>/*.so <~/maple2020>
bash: syntax error near unexpected token `14539'"

1.1 * 10^2

but export text become two lines

               2

1.1 *   10

pretty printing = 3 

but still two lines

 

how to export in one line such as 10^2 ?

               

I want to insert each row at a time into a excel sheet from a maple code .  But i dont want a new excel file created for each insert.

First my list L has say [(a,1),(a,2),(a,3),.....,(a,100)] 100 elements this is first i insert it into my excel first row
next  [(b,1),(b,2),(a,3),.....,(b,100)] 100 elements i should insert into excel second row and so on

but dont want to store them here on a rtable, vector,array "all together" then export

I justt store 1 row at a time insert it and do on the same excel file file dynamically. without creating multiple copies of the same file

can anyone help with a code using exceltools package or any

 

Suppose i have a set say

 

A={{"1"."8"},{"1","4"},{"1","10"}}

if i want to convert A to set such that {"{"1"."8"}","{"1","4"}","{"1","10"}"}  where each element is a string with minium time I have given a small set here i may have set with 48 to 100 such element that is s set of sets i want to convert the inside sets to strings without much of looping in minimum time can any one help


 

``assume(0 < k, k < 1)

int(x^2/sqrt((-x^2+1)(-k^2*x^2+1)), x = 0 .. k)

int(x^2/(-x(-k^2*x^2+1)^2+1)^(1/2), x = 0 .. k)

(1)

sqrt(k^2)

k

(2)

``


 

Download ellipticIntegralTest.mw

Hi everyone, 

I am trying to use elliptic integral from Maple, however, it did not generate any result. Can you help me with that?

let me just explains the big picture first, then give small example.

When using standard modules, I had one module, and number of smaller modules, all private to the main module. This worked well.

Each sub module, can only be accessed from the top module, which is seen by user. The sub modules can't be called by user directly.

Now I changed the main module to become an object (since I want to make more instances of it).

I want to still use the code in those submodules I had, but want to keep them private to the object class, so they can be seen only from inside the object class methods. So they are part of the object class now. But remain as modules. I do not want to copy all those methods in these submodules and put them in the object class directly.

But I can't get the syntax right to do this. I do not want to modify the code inside the sub-modules, but only how to integrate them into the object.

Notice that I can call those external modules fine from the object, but I simply want to make them private to the object class, so they can't be called from outside. 

The question is how to do this? 

Here is a very small example. (in practice, I have these submodules in .mpl files, but here I put them all in the example).

restart;	
module car_class()
      option object;
      local name::string :="UNKNOWN";

      export set_name::static:=proc(o::car_class,_name::string)
        o:-name := _name;
        o:-big_car:-set_name(o,_name);#this call does not work
      end proc;

      #this is module, that I want to be private to this class only
      #eventually, I'd like this module be in separate mpl file also.
      local big_car::static :=module()  #module does not take arguments!

            #this below should be private only to the this module
            #and not seen by the enclosing object.
            local big_car_name::string:="UNKNOWN";  

            #this export to allow parent object to call it
            export set_name::static:=proc(o::car_class,_name::string)
                   o:-big_car:-big_car_name:=_name;
            end proc;

      end module;

end module:

o:=Object(car_class);
o:-set_name(o,"GM");

Error, (in set_name) module `car_class` does not export `big_car`

I found after playing more with it, that this works

I just replaced o:-big_car:-big_car_name:=_name;  with big_car:-big_car_name:=_name; had to remove ::static from definition of proc inside the private module.

restart;	
module car_class()
      option object;
      local name::string :="UNKNOWN";

      export set_name::static:=proc(o::car_class,_name::string)
        o:-name := _name;
        o:-big_car:-set_name(o,_name);
      end proc;

      local big_car::static  :=module() 
          local big_car_name::string:="UNKNOWN";  

          export set_name:=proc(o::car_class,_name::string)
              big_car_name:=_name;
          end proc;

     end module;
end module:

Now it works. However, maple help says "In Maple, method names should be declared as static. "

I would like to factor

factor(98-28*sqrt(7));

which I would like to output 14*(7 - 2*sqrt(7)),

but Maple keeps returning 98 - 28*sqrt(7).

code_(1).mw
 

 

 

Hello! hope you all be fine. i m running a code for `Anew Technique of intial Boundary Value Problem Using ADM `(Elaf*Jaafar*Ali) but my code is for positive integer and i want to run it for fractional can anyone help me please code file is attached 

 

If one refers to a name in Maple, I thought it will look at the global context to find it. So when one does latex(....) then this is assumed to be the system latex command. No need to do :-latex()

But if there is local variable in Object class called latex, why then is object:-latex gets confused with global Maple command latex()?  Here is an example

module ode_class()
      option object;
      local latex::strring :="";

      export init::static:=proc(o::ode_class)
        o:-latex:= latex(1/2,output=string);
      end proc;
end module:

my_ode:=Object(ode_class): 

Error, static procedure `ode_class:-init` refers to non-static local or export `ode_class:-latex::strring` in surrounding scope
 

ofcourse easy to fix, I just replace the RHS latex(1/2,output=string);  with :-latex(1/2,output=string); 

But my question why is object:-latex := latex(...)  makes Maple think the latex in the RHS is the variable name in the class, when it does not have the  object:- prefix?  Is this expected  behaviour in Maple? 

But now I am starting to worry that each maple command/function/name used inside the Object needs  :- added to it, just in case of a current or future name conflict with local object variables names.

 

 

For example the below is a c code how to write this in maple

 

void swap(int *a, int *b)

 {

     int temp;

emp = *a;

*a = *b;    

 *b = temp;  

}    //permutation function

 void permutation(int *arr, int start, int end)

 {      

if(start==end)

     {        

 printarray(arr, end+1);

         return;    

 }      

int i;    

 for(i=start;i<=end;i++)  

   {          //swapping numbers      

   swap((arr+i), (arr+start));      

   //fixing one first digit          //and calling permutation on          //the rest of the digits          permutation(arr, start+1, end);          swap((arr+i), (arr+start));  

   }  

}

Could anyone help me with how to open an .m file in Maple in Windows? Thanks a lot.

First 8 9 10 11 12 13 14 Last Page 10 of 1900