Unanswered Questions

This page lists MaplePrimes questions that have not yet received an answer

integral of sqrt(sin(x)) is known to be as given in few place such as in here and other places.

Maple gives a result which is much more complicated (but also in terms of EllipticE special function). 

Could someone find a way to simplify it to the above answer and also to the same answer given by Mathematica?

int(sqrt(sin(x)),x)

Compare to 

Maple's result seems to be correct, as I plotted it and compared the smaller known resut. But I was not able to simplify it to obtain the smaller antiderivative.

Any tricks to do that?

Hi all

I need your advice on Maple usage after a long break. I installed Maple on my laptop and first of all tried to launch my old program. Surprisingly, the old file opened. While the core Maple functionality remained familiar, the user interface had undergone some changes.

Yet, I soon encountered challenges when attempting to perform even the simplest operations, like file browsing or text selection; the Maple Standard GUI seemed uncharacteristically sluggish.  I switched to Maple Input mode but it didn't help much. Are there ways to improve my experience with Maple? Is it caused by the outdated hardware?

My system:
Ubuntu 22.04.3 LTS
Dell Inc. Latitude 5510 (1TB SSD, 32GB RAM).

Maybe it works much better on Windows?

Thank you for any suggestions.

Modal Analysis is a very usefull feature. Only the animation window is sometimes too tiny.

How to enlarge this view and to pause the animation?

This seems to be a Maple plot window (a "Rotate the view" cursor is visible and the animation can be rotated). Are there any short cuts or functions keys to toggle plot view options?

Edit: Looks to my like a Maplet. Maybe a Maplet programmer can tell if that (what I am asking) is possible

Hi, 

Some of my maple documents contain data tables. 

When I want to view these documents with the maple cloud viewer, the data tables are invisible (the table is completely grayed out) and it is therefore impossible to change the values in this table. 

The table properties are such that it is enabled, visible and editable. 
Does anyone have an idea how to solve this problem? 
Thanks in advance. 

Whats the best way to let a Maple-Code run in webspace.

The Maple-Procedure gets some parameters from a mobile-App. Then doing calculations and giving back data as a file to the mobile app.

I have alomost decided for Deno which accepts Javascript. This is develeoped by Ryan Dahl who has also created Node.

Deno is more compact and very fast. So I when I use a deno server code  then I need the Maple-Code in language Javascript.

I have tried to translate some maple-subprocedures of my code with CodeGeneration but this is very restricted I think.

Thanks for ideas :)

Both, Maple and MapleSim in Versions from 2021 to 2023 do not start. A logfile is saved which starts as

# A fatal error has been detected by the Java Runtime Environment:

#

#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000000000000, pid=17256, tid=10520

#

# JRE version: OpenJDK Runtime Environment Temurin-19.0.1+10 (19.0.1+10) (build 19.0.1+10)

# Java VM: OpenJDK 64-Bit Server VM Temurin-19.0.1+10 (19.0.1+10, mixed mode, tiered, compressed oops, compressed class ptrs, g1 gc, windows-amd64)

# Problematic frame:

# C  0x0000000000000000

#

This only occurs when the notebook (on which the error occurs) is connected to the domain network. If the notebook is not connected, Maple and MapleSim can be started and will continue to run when the network is reconnected.

Has anybody seen this before or any ideas what this could be?

Edit: This all happened under Windows 10 on a notebook that has been running Maple for 3 years and only recently displayed this error.

Edit2: Connection via an USB doc which also connects to an external monitor.

The worksheet below includes a sample use of the Mobius transformation which produces a hyperbolic reflection of a point in the Poincare disk, followed by my attempt to produce the same result from first principles in a procedure.

Do I misunderstand the Mobius transformation and its use and/or is my procedure incorrect? 

InversePoint.mw

Soit h : [1 ; + ∞[ℝ

1.a°) Complète le tableau ci-dessus et trace la courbe ( Ch) de h dans un repére orthonormé ( O,I,j )

 𝑥 1 2 3 4 5

h(𝑥 )

b°) Montre que h est une bijection

c°) Détermine la bijection réciproque h-¹ de h

d°) Calcule hoh-¹ et h-¹oh ( 𝑥 )

2.) Trace la courbe ( Ch-¹) dans le même repére que ( Ch)

Hello,
I recently discovered the "Physics" package wich provides tools for manipulating abstract vectors (non-component).
In the "Physics:-Vectors", an orthonormal basis (i,j,k) is available and my main concern is how to generate arbitrary other 3D orthonormal bases to be able to calculate results in "vectorial form" without manipulating vectors' components.

To better explain my needs I have setup a kind of minimal example in the attached file where some questions are asked.

Thanks in advance for any feedback.

orthonormal-triads.mw

NULL

restart

with(Physics)

with(Physics[Vectors])

Creation of 2 rotation matrices

dir1 := `<,>`(0, 0, 1)

dir2 := `<,>`(0, 1, 0)

seq(assign(cat(R, i), Student:-LinearAlgebra:-RotationMatrix(theta[i], eval(cat(dir, i)))), i = 1 .. 2)

print(R1, R2)

Matrix(%id = 36893490614987576012), Matrix(%id = 36893490614987577572)

(1)

whattype(R1)

Creation of  orthogonal unit "Physics:-Vectors" from previous matrices

x1_ := _i*R1[1, 1]+_j*R1[2, 1]+_k*R1[3, 1]``

y1_ := _i*R1[1, 2]+_j*R1[2, 2]+_k*R1[3, 2]

z1_ := _i*R1[1, 3]+_j*R1[2, 3]+_k*R1[3, 3]NULL

NULL

x2_ := _i*R2[1, 1]+_j*R2[2, 1]+_k*R2[3, 1]NULL

y2_ := _i*R2[1, 2]+_j*R2[2, 2]+_k*R2[3, 2]

z2_ := _i*R2[1, 3]+_j*R2[2, 3]+_k*R2[3, 3]

Q1: Is there a more elegant way of creating "Physics:-Vectors" from matrices ?

Now, suppose that we want to compute `&x`(`#mover(mi("x1"),mo("&rarr;"))`, `#mover(mi("y2"),mo("&rarr;"))`) : since `#mover(mi("y2"),mo("&rarr;"))` = `#mover(mi("j"),mo("&and;"))` we have `&x`(`#mover(mi("x1"),mo("&rarr;"))`, `#mover(mi("y2"),mo("&rarr;"))`) = sin(`#mover(mi("x1"),mo("&rarr;"))`, `#mover(mi("j"),mo("&and;"))`)*`#mover(mi("z1"),mo("&rarr;"))` and sin(`#mover(mi("x1"),mo("&rarr;"))`, `#mover(mi("j"),mo("&and;"))`)*`#mover(mi("z1"),mo("&rarr;"))` = sin((1/2)*Pi-`&theta;__1`)*`#mover(mi("z1"),mo("&rarr;"))` and sin((1/2)*Pi-`&theta;__1`)*`#mover(mi("z1"),mo("&rarr;"))` = cos(theta[1])*`#mover(mi("z1"),mo("&rarr;"))`

The cross product operator  `&x`(x1_, y2_) yields

cos(theta[1])*_k

(2)

(which is a correct answer) instead of cos(theta[1])*`#mover(mi("z1"),mo("&rarr;"))` because vector `#mover(mi("z1"),mo("&rarr;"))` has is not known as a unit basis vector.

Similarly, `&x`(z1_, x1_) yields -sin(theta[1])*`#mover(mi("i"),mo("&and;"))`+cos(theta[1])*`#mover(mi("j"),mo("&and;"))` instead of  `#mover(mi("y1"),mo("&rarr;"))` as it would be the case when computing `&x`(_k, _i) ?

Q2: Is there a way to declare new triads of "Physics:-Vectors" with properties similar to the provided triad _i, _j, _k ?

Q3: Is the code defining the canonical basis i, _j, _kavailable for inspection and inspiration to setup orthonormal triads ?

Q4: Is it possible to get a (column) matrix of the vector components ? The function Physics:-Vectors:-Component(y1_, n) can only get 1 component at a time and only in the canonical basis i, _j, _k.

NULL

restart

with(Physics)

with(Physics[Vectors])NULL

After a proper definition of 2 new vector bases `#mover(mi("x1"),mo("&rarr;"))`, `#mover(mi("y1"),mo("&rarr;"))`, `#mover(mi("z1"),mo("&rarr;"))` and `#mover(mi("x2"),mo("&rarr;"))`, `#mover(mi("y2"),mo("&rarr;"))`, `#mover(mi("z2"),mo("&rarr;"))`, the position vector OM_ := l__1*x1_+l__2*x2_NULLNULL

l__1*x1_+l__2*x2_

(3)

NULL

projected on `#mover(mi("x2"),mo("&rarr;"))` would yield directly Typesetting[delayDotProduct](l__1, `#mover(mi("x2"),mo("&rarr;"))`.`#mover(mi("x1"),mo("&rarr;"))`, true)+l__2 instead of expand(OM_.x2_)

l__1*Physics:-Vectors:-`.`(x1_, x2_)+l__2*Physics:-Vectors:-Norm(x2_)^2

(4)

because of the unit vectors.

Download orthonormal-triads.mw

This used to work in Maple 2022.  Something is broken in 2023. 

 

restart;

kernelopts(version);

`Maple 2023.1, X86 64 LINUX, Jul 07 2023, Build ID 1723669`

Physics:-Version();

`The "Physics Updates" version in the MapleCloud is 1561 and is the same as the version installed in this computer, created 2023, October 20, 22:58 hours Pacific Time.`

U := Int(exp(-1/4*t - 1/4*x)*piecewise(x < -2, 1, x < -1, -x - 1, 0), x = -t .. 0);

Int(exp(-(1/4)*t-(1/4)*x)*piecewise(x < -2, 1, x < -1, -x-1, 0), x = -t .. 0)

Uval := simplify(value(U));

Uval := `simplify/piecewise/unfactor`(4*piecewise(t < 1, 0, t < 2, t-5+4*exp(`&ndash;`((1/4)*t)+1/4), 2 <= t, 1+4*exp(`&ndash;`((1/4)*t)+1/4)-4*exp(`&ndash;`((1/4)*t)+1/2)))

eval(Uval, {x=5, t=6});

`simplify/piecewise/unfactor`(4+16*exp(-5/4)-16*exp(-1))

 
 

Download simplify-piecewise-bug.mw

 

The following test program (Test.cpp) fails with.L + Test.cpp+, but not with plain .L, nor with gcc. It also does not tell me anything about why where it fails!

#include <string>
int Test(std::string x) {
cout << x << "\n";
 return 1;
};

Error in <ACLiC>: Executing 'C:\root_v6.28.06\bin\rootcling -v0 "--lib-list-prefix=C:\Users\snyde\BFROOT\ROOT\Test_cpp_ACLiC_map" -f "C:\Users\snyde\BFROOT\ROOT\Test_cpp_ACLiC_dict.cxx"  -rml Test_cpp -rmf "C:\Users\snyde\BFROOT\ROOT\Test_cpp.rootmap" -DR__ACLIC_ROOTMAP -I%ROOTSYS%\include -D__ACLIC__  "C:/Users/snyde/BFROOT/ROOT/Test.cpp" "C:\Users\snyde\BFROOT\ROOT\Test_cpp_ACLiC_linkdef.h"' failed!

Huh? Why?

I can't learn what's wrong using 'g++  -c Test.cpp' (outside ROOT)  as it compiles w/o complaint in that case.

Is there a way to get ROOT to tell us what it objects to?

How I can solve the error in maple which is ( (in PDEtools:-DeterminingPDE) expected the number of infinitesimals (4) to be equal to the sum of the number of independent (2) and dependent (1) variables; received: 4 <> 2 + 1)

I would like to create a database of component information. I have previously done this using a table which is indexed by the part number. Each element is a DataFrame, which includes several items with values and at least 2 DataFrames. The 2 DataFrames are extracted from a Spreadsheet with 2 tabs, that is stored in a Maple Workbook. Each DataFrame has an name for the row and 2 columns; Description and Value. The Description is text and the value is a single value or 3-element list with unit. Such at [9, 10, 11]*~Unit('ohm')

Anyway, I'm wondering if this is the most efficient way. I'm also wondering if there is a way to create such a database so it can be used with other software tools, primarily Mathcad and Excel.

Thanks

I found this option in an API command ?MapleSim,LinkModel,Simulate:

    scalemethod : one of the following: "none", "minimum", "maximum", "geometric"
    Method of variable scaling applied to the system.

I did not find anything about scaling in Maples help system.

What exactly does the scaling do?

 In the memory leak problem with my DStarLepNu simulation program, I did find one cause in that due to normalization errors the accept/reject algorithm in ‘PickAngles’ was executed too many times. This should have just made angle generation inefficient but occasionally, but not always produced very big memory bumps when a large number of trials were needed to pick angles. It’s not clear why these bumps occurred as the code being executed is always the same and is simple.

Fixing this did however not prevent memory crashes or even reduce them much.

I have since turned off accept/rej and calls to ‘arccos’ and more modest spikes remain and crashes still occur!

I don’t understand how Maple memory management works. My B-meson decay prov ‘bDecay’ usually gives  still shows occasional spikes and and there’s a weird correlation between the first (B1) and second (B2) call:

 

DStar3DKinRecoLoopDebugCombo200EventsExportRun2.mw

 

çMemory added by ‘bDecay’ proc on 1st call vs 2nd call in the B1-B2 event loop..

èWhat with the slope and difference in width?

First 6 7 8 9 10 11 12 Last Page 8 of 332