Unanswered Questions

This page lists MaplePrimes questions that have not yet received an answer

I run Maple 2021 under Ubuntu 20.04 on a new Lenovo laptop with 32Gb of Ram. Every time I start Maple, it runs for a few minutes and then loses the "kernel connection". I have to save the worksheet and re-start Maple. In dmesg, I find:

[ 1436.724570] oom-kill:constraint=CONSTRAINT_NONE,nodemask=(null),cpuset=/,mems_allowed=0,global_oom,task_memcg=/user.slice/user-1000.slice/user@1000.service,task=mserver,pid=8037,uid=1000
[ 1436.724589] Out of memory: Killed process 8037 (mserver) total-vm:31723552kB, anon-rss:31289772kB, file-rss:60kB, shmem-rss:0kB, UID:1000 pgtables:61656kB oom_score_adj:0
[ 1437.151441] oom_reaper: reaped process 8037 (mserver), now anon-rss:0kB, file-rss:0kB, shmem-rss:0kB

indicating that Maple's virtual memory exceeded 30 Gb! This happens even if the only command I execute is, for instance, "resrart" or "A:=1" and nothing else. It also happens when no other applications are running and the "top" command indicates that around 30Gb of RAM is available.

In this state, Maple is utterly useless to me. This was a new install of Maple and a fresh install of Ubuntu on a new laptop, surely I am not the only one seeing this?

I have tried setting a 30Gb limit in "kerneloptions" for "stacklimit" but that di not make a difference.

If you have seen any behaviour like this, please respond. Is there some bug in Maple that leads to oncontrolled and unprovoked memory grabbing?

I can export a worksheet (to many different formats), but the normal way of doing this requires a human in the loop and several mouse operations.

Is there a way to automate this?

I have on the order of 100 different worksheets and would like to capture them in an archival format (e.g., PDF).

> with(LinearAlgebra) :
> a:=<<.1,.2>|<.3,.4>>:
> ScalarMultiply(a,.1);

INTEL MKL ERROR: /home/jet08013/maple2022/bin.X86_64_LINUX/libmkl_gf_lp64.so: undefined symbol: mkl_blas_cdgmm_batch_strided.
Intel MKL FATAL ERROR: Cannot load libmkl_gf_lp64.so.
maple: fatal error, lost connection to kernel

This is EXTREMELY inconvenient.

ImportGraph reads one or more graphs from a file. For a file containing multiple graphs, the supported formats are digraph6, graph6, and sparse6. I notice that one option is "output = graph or list, or iterator". However, in my programming with Maple, I was reminded several times that list is only good for a small amount of data.  

Although I can convert the list to an array using the convert function, the time spent in the conversion process needs to be considered.

L:=ImportGraph("C:/Users/eul10c.g6", graph6, output=list):#31026 connected eulerian graphs on 10 vertices graphs and Change to your path here.

So does it make more sense to provide an "output=Array" as an output option?


When resizing a textplot the text is not scaled. 

In a multibody assembly I have three instances of identically connected prismatic joints (flanges not conneted and identical componets at the frames)

In the simulation results the joints are listed with the following variables:

Why are the variables not the same for three identical components and what do the Fi and Mi stand for?

Is there any documentation on variables listed in the simulation results? It seems that more variables can be available than listed in the component documentation.

I have reported this to Maplesoft. There is a problem (on LInux 20.2) that has to do with java. I have (well, I had) a large project. Around 1500 lines when I cut and pasted into a word processor. (No, I was not editing in the word processor, I just needed a way to put a number on the size that was better than, "quite large". )

I do my editing in 2D math. The other is not an option, and I kind of doubt it would matter.

There is a problem in 2022,  in which,  after working in the editor for 3-5 hours, it gets very slow. CPU use will go into the 80% range. Java will have 1.7 GB or RAM allocated to it. The editor  becomes impossible to use. The only cure is to save the file, then re-open it after shutting down Maple. If Java goes away in system monitor (Linux version of Taskmanager) then it will work fine when it comes back. This appears to me to be a bug in handling of java, in which Maple never lets go of memory, and some piece of code goes off into all that RAM to do something. I have waited as long as half an hour. That time I gave up and killed the java task which ended Maple.

Just now, what prompted this post, in addition, is that when I brought Maple back up for the (2-3 times per day complete restart due to this problem) the file I had just saved is now corrupted, and truncated. A lot of work is gone, and no way to retrieve it I know of. The file is now less than half the size it was (43% of the size of the previous version number).

I told support that this release is acting like beta software, despite being the regular release.

Be careful. Increment your saved versions of .mw files regularly. Save regularly. Expect problems.

Configuration: Intel i7 CPU, 64 GB RAM. Note that earlier versions of Maple sometimes got memory use up to 12 GB on other sheets. I have not noticed what Java was using prior to this.

I noticed that someone changed this to a "performance" tag. It is not really about performance. This shows up as the editor is a bit slow, and then suddenly the editor is off in the weeds for a while. This is a serious memory management problem. It is also a bug that killed a day's work, and if I hadn't been lucky more than a day. Maple should not destroy files when it writes them out.

Please don't arbitrarily recategorize a bug without fully reading the problem.

I was able to fix the problem. But I wanna use if statements to differentiate between complex and real roots in the attached file below:SOLVING_SYS.mw.


I want to extract the highest linear and non-linear terms in an equation without their coefficients

How I can do it?

For example in the following equation, the highest linear and nonlinear without coefficients are diff(u(T),T$3) and u(T)*diff(u(T),T), respectively.


Thanks in advance.

Maple 2022:

It appears that one can use push_back() with an empty DEQueue(), but not push_front().

Since the queue is double-ended and empty, this doesn't make much sense to me. So should this be considered a "bug"?

See the attached


# This works

module DEQueue () local num, head, tail, storage, dsp; option object; end module




module DEQueue () local num, head, tail, storage, dsp; option object; end module


# But this results in an error!

module DEQueue () local num, head, tail, storage, dsp; option object; end module




Error, invalid return value from method moduledefinition: 'NULL'



Download DEQueue_Prob.mw

A question by @Shameera  I was working on has disapeared meanwhile.
It was related to this previous thread 233822-How--To-Solve-This-Equation-By-Using but has not been displaced in it.
Did a regolaror do this or was it  @Shameera ?

I have seen that this is possible (for example in the example:  2-D Flexible Spin-up Beam).

When I copy an image to the Windows10 clipboard it does paste to other applications but not to MapleSim. Instead, I get an audio notification from the system that is played on other instances when an action cannot be performed.

Within MapleSim copy and paste works (also between models). However, copying an image from a Maplesim Model to another Windows App does not work.

Can someone confirm that pasting images works in recent verions?

(Clearing the Clipboard removes images copied with MapleSim.

Observed on 2 Windows 10 installations with the version 2022 and 2021.)

function is F(x)= x-tanh(4*x/T) and diff(F(x))= 1-(4/T)*(1/T*Cosh(4*x/T)^2). x and t variable T max value=7, i want to do plots ising models function. Anyone can help me?

Graphich will be this 


I have not found anything in the corresponding help page and mouse over does not work.


2 3 4 5 6 7 8 Last Page 4 of 298